Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 767
  • Last Modified:

Microsoft Remote Connectivity Analyzer Pulling the wrong SSL certificate

When I do Microsoft Remote Connectivity Analyzer Test, It appears the test is pulling a SSL certificate from our main company website and not getting the cert from our exchange server. When I launch EMC, go to Server configuration, under Exchange certificates, I see the correct certificate.

Thanks,
0
AJola
Asked:
AJola
  • 2
  • 2
  • 2
  • +2
1 Solution
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Is there some ISA or some Firewall still not updated with the new SSL cert ??

- Rancy
0
 
AJolaAuthor Commented:
How do I check Randy?

What i am trying to resolve is "calender Sharing" for outside domain users. We have exchange 2010 and users are on outlook 2010.

Also attached is  auto discover test result just for more information
Autodiscover-Issue.jpg
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
If you have any Firewall or other app you should contact vendor to understand if it too works with Certs and how to update them

Also have you got the Autodiscover DNS record created

- Rancy
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
AJolaAuthor Commented:
Hi Rancy Yes I have the autodiscover DNS record created.

Attached is a pic, when i do the test for Autodiscover internally inside the domain and it's successful.

My concern is when I do the autodiscover test it's pulling a SSL certificate from our main company website and not getting the cert from our exchange server.

Our main website is hosted somewhere else.

Please Help!
Autodiscover-succed.png
0
 
Cliff GaliherCommented:
Sounds like you have a wildcard external DNS record. That'll break autodiscover every time.  Fix hat and things should work. The remote connectivity analyzer tells younwhich DNS lookup returned the cert in its logs.
0
 
RadweldCommented:
In you r example, the Autodiscover settings internally are being presented by a service connection point (SCP) this is an advertised service on a domain and not available externally. For that work the Autodiscover address must resolve to your exchange server, as the tests are retrieving a different severs details, this suggests Autodiscover isn't pointing to the correct server.
0
 
ChrisCommented:
it certainly looks like creating an external autodiscover SRV record will do the trick as the testconnectivity will always look for that first. You might have to ask your ISP to set it up if you don't fully manage your own dns as most web consoles don't let you add SRV's


Service: _autodiscover
Protocol: _tcp
Port Number: 443
Host: mail.yourdomain.com
0
 
Cliff GaliherCommented:
Nope. The SRV record is the LAST method used, not the first. The SRV record is a completely legitimate approach, but if other DNS or SSL certificates are misconfigured, then the certificate prompt will still appear because the other methods will trigger it before thenSRV record is even queried.
0
 
ChrisCommented:
yes you are right. there should be a plain A record for autodicover as well.
But it is only picking those up because there is some kind of wildcard DNS record, otherwise they would fail and the SRV record would kick in
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 2
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now