Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Adprep /rodcprep Fails

Posted on 2013-06-24
11
1,463 Views
Last Modified: 2013-06-30
When I run adprep /rodcprep it gives me this error message. Any idea how I can fix this? We did have a server that we were replicating to crash a few years back and we did not replace it. I am guessing that is what is causing the problem. This is all in preparation of adding a new 2008 server to take over the DC role.

C:\Documents and Settings\Administrator.TBA>E:\support\adprep\adprep32.exe /rodc
prep
Adprep connected to the domain FSMO: tba-dc001.tba.local.


==============================================================================
Adprep found partition DC=DomainDnsZones,DC=tba,DC=local, and is about to update
 the permissions.


Adprep could not contact a replica for partition DC=DomainDnsZones,DC=tba,DC=loc
al.

Adprep encountered an LDAP error.
Error code: 0x0. Server extended error code: 0x0, Server error message: (null).



Adprep failed the operation on partition DC=DomainDnsZones,DC=tba,DC=local. Skip
ping to next partition.
==============================================================================


==============================================================================
Adprep found partition DC=ForestDnsZones,DC=tba,DC=local, and is about to update
 the permissions.


Adprep could not contact a replica for partition DC=ForestDnsZones,DC=tba,DC=loc
al.

Adprep encountered an LDAP error.
Error code: 0x0. Server extended error code: 0x0, Server error message: (null).



Adprep failed the operation on partition DC=ForestDnsZones,DC=tba,DC=local. Skip
ping to next partition.
==============================================================================


Adprep detected the operation on partition DC=tba,DC=local has been performed. S
kipping to next partition.
==============================================================================


Adprep completed with errors. Not all partitions are updated. See the ADPrep.log
 in the C:\WINDOWS\debug\adprep\logs\20130624131829 directory for more informati
on.

To successfully update all partititions, the current logged on user needs to be
a member of Enterprise Admins group.  If that is not the case, please correct th
e problem, and then restart Adprep.



C:\Documents and Settings\Administrator.TBA>
0
Comment
Question by:tbawarehouse
  • 7
  • 4
11 Comments
 

Author Comment

by:tbawarehouse
ID: 39272428
Here is what the log says -

[2013/06/24:13:18:29.088]
Adprep created the log file ADPrep.log under C:\WINDOWS\debug\adprep\logs\20130624131829 directory.
[2013/06/24:13:18:29.103]
Adprep connected to the domain FSMO: tba-dc001.tba.local.
[2013/06/24:13:18:29.103]
Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is (null).
[2013/06/24:13:18:29.103]
LDAP API ldap_search_s() finished, return code is 0x0
[2013/06/24:13:18:29.103]
Adprep successfully retrieved information from the local Active Directory Domain Services.
[2013/06/24:13:18:29.119]
Adprep successfully initialized global variables.

[Status/Consequence]

Adprep is continuing.
[2013/06/24:13:18:29.119]
Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is CN=Partitions,CN=Configuration,DC=tba,DC=local.
[2013/06/24:13:18:29.119]
LDAP API ldap_search_s finished, return code is 0x0
[2013/06/24:13:18:29.119]
==============================================================================

Adprep found partition DC=DomainDnsZones,DC=tba,DC=local, and is about to update the permissions.
[2013/06/24:13:18:29.134]
Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is CN=Infrastructure,DC=DomainDnsZones,DC=tba,DC=local.
[2013/06/24:13:18:29.134]
LDAP API ldap_search_s finished, return code is 0x0
[2013/06/24:13:18:29.134]
Adprep could not contact a replica for partition DC=DomainDnsZones,DC=tba,DC=local.
[2013/06/24:13:18:29.150]
Adprep encountered an LDAP error.

Error code: 0x0. Server extended error code: 0x0, Server error message: (null).
[2013/06/24:13:18:29.150]
Adprep failed the operation on partition DC=DomainDnsZones,DC=tba,DC=local. Skipping to next partition.

==============================================================================
[2013/06/24:13:18:29.166]
==============================================================================

Adprep found partition DC=ForestDnsZones,DC=tba,DC=local, and is about to update the permissions.
[2013/06/24:13:18:29.166]
Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is CN=Infrastructure,DC=ForestDnsZones,DC=tba,DC=local.
[2013/06/24:13:18:29.181]
LDAP API ldap_search_s finished, return code is 0x0
[2013/06/24:13:18:29.181]
Adprep could not contact a replica for partition DC=ForestDnsZones,DC=tba,DC=local.
[2013/06/24:13:18:29.197]
Adprep encountered an LDAP error.

Error code: 0x0. Server extended error code: 0x0, Server error message: (null).
[2013/06/24:13:18:29.197]
Adprep failed the operation on partition DC=ForestDnsZones,DC=tba,DC=local. Skipping to next partition.

==============================================================================
[2013/06/24:13:18:29.213]
Adprep detected the operation on partition DC=tba,DC=local has been performed. Skipping to next partition.

==============================================================================
[2013/06/24:13:18:29.228]
Adprep completed with errors. Not all partitions are updated. See the ADPrep.log in the C:\WINDOWS\debug\adprep\logs\20130624131829 directory for more information.



To successfully update all partititions, the current logged on user needs to be a member of Enterprise Admins group.  If that is not the case, please correct the problem, and then restart Adprep.


FYI the Administrator is a part of the Enterprise Admins Group.
0
 
LVL 3

Expert Comment

by:CITG_Carl
ID: 39272512
How many domain controllers do you have on your Domain? It sounds like its failing to connect to a stale domain controller hence why your getting LDAP errors

did ADPREP /prepforest or /prepdomain or /prepschema work fine?

Cheers
0
 

Author Comment

by:tbawarehouse
ID: 39272539
We just have one DC but had another DC 2 years ago that crashed. We never replaced it.

I ran forestprep and domainprep with no errors.
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 3

Expert Comment

by:CITG_Carl
ID: 39272549
The domain controller that crashed, was it removed from the domain correctly?

if you look in the 'Domain Controllers' container in ADUC is it still listed? Or run repadmin /replsummary
0
 

Author Comment

by:tbawarehouse
ID: 39272579
It is not within Domain Controllers under ADUC. Where is the repadmin file located? Can't seem to find it..
0
 
LVL 3

Expert Comment

by:CITG_Carl
ID: 39272582
run that command in CMD. repadmin /replsummary

This will return back any configured or semi-configured domain controllers
0
 
LVL 3

Expert Comment

by:CITG_Carl
ID: 39272585
Sorry just a side thought.

Are you actually planning on installing a read only domain controller onto the domain?
0
 

Author Comment

by:tbawarehouse
ID: 39272648
Odd...that command doesn't work. Says it is not recognized. Does it need to be installed from the 2003 server CD?

We are planning on promoting the 2008 server once the replication is done and demoting the 2003 server.
0
 

Author Comment

by:tbawarehouse
ID: 39272678
C:\Program Files\Support Tools>repadmin /replsummary
Replication Summary Start Time: 2013-06-24 15:10:44

Beginning data collection for replication summary, this may take awhile:
  ....


Source DC           largest delta  fails/total  %%  error


Destination DC    largest delta    fails/total  %%  error
Assertion


C:\Program Files\Support Tools>

This is what i get when i run that command
0
 

Accepted Solution

by:
tbawarehouse earned 0 total points
ID: 39274857
http://support.microsoft.com/kb/949257 - this article seems to be the fix. I am unsure of how to run this script. Anyone have any ideas?
0
 

Author Closing Comment

by:tbawarehouse
ID: 39287900
I found the Microsoft article.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of us need to configure DHCP server(s) in their environment. We can do that simply via DHCP console on server or using MMC snap-in on each computer with Administrative Tools installed in a network. But what if we have to configure many DHCP ser…
I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question