Solved

WCF Service Error

Posted on 2013-06-24
4
409 Views
Last Modified: 2013-06-30
Hi,
I am consuming a WCF service in Classic ASP web application using SOAP calls.
I am getting the following error.

Object reference not set to an instance of an object
SyncInvokeAuthorizeIdentity(Object , Object[] , Object[] ) 
at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc) at 
System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
System.NullReferenceException  

Open in new window


I tried to google for some of these exceptions. But, I couldn't find any solution.

Can you guys please help me in this?

Thanks
Padu
0
Comment
Question by:spraocs
  • 2
  • 2
4 Comments
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
Comment Utility
Please let us know which webservice you are using and please post your code taking out any passwords.  If your code is very long, post only what is needed to answer this question.  How you are building the soap envelope, httppost and reading response.

Include what line where the error was.
0
 
LVL 1

Accepted Solution

by:
spraocs earned 0 total points
Comment Utility
Thanks for responding.
Sorry, I think I jumped in too early. I was missing a tag in the soap message body. But the error message posted above didn't give me any clue about that. So, I had to post a question here.. closing this question now.
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
Comment Utility
That's what I figured.
0
 
LVL 1

Author Closing Comment

by:spraocs
Comment Utility
I was missing a tag as mentioned in my previous post.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

I recently decide that I needed a way to make my pages scream on the net.   While searching around how I can accomplish this I stumbled across a great article that stated "minimize the server requests." I got to thinking, hey, I use more than one…
I was asked about the differences between classic ASP and ASP.NET, so let me put them down here, for reference: Let's make the introductions... Classic ASP was launched by Microsoft in 1998 and dynamically generate web pages upon user interact…
The purpose of this video is to demonstrate how to set up the WordPress backend so that each page automatically generates a Mailchimp signup form in the sidebar. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now