• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 756
  • Last Modified:

How to: Delete zones from Windows Sever 2008 - DNS Server Management?

Trying to delete a reverse lookup DNS zone using the command line approach.

dnscmd localhost /zonedelete 0.in-addr.arpa /dsdel

I receive the following error: DNS_ERROR_INVALID_ZONE_TYPE 9611

Am I doing something wrong here?
1 Solution
Its AD integrated zone or standalone dns? if its a standalone dns remove the /dsdel in the command. /dsdel is for AD integrated zones only.

Note the addition of /dsdel to the command. This is require to remove the zone from AD if it is AD integrated. Otherwise you will receive an error such as DNS_ERROR_INVALID_ZONE_TYPE 9611. If you are working with a non-AD integrated zone then it is fine without /dsdel.

Refer the below

cgruberAuthor Commented:
Its an AD integrated zone.

I tried both, with and without. No go.
Is this correct format of your reverse zone 0.in-addr.arpa .? Have you tried to delete it directly from dnsmgmt.msc.
We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

cgruberAuthor Commented:
Yes, delete is not an option appearing when right clicking on it.
SandeshdubeySenior Server EngineerCommented:
You are missing some octet.Below is the sample example
C:\>dnscmd /zonedelete 1.168.192.in-addr.arpa /dsdel

You can also connect to ADSIEDIT and delete the reqruired zone.
VirastaRUC Tech Consultant Commented:

According to the Technet -

Delete a Zone

This is the Syntax

dnscmd <ServerName> /ZoneDelete <ZoneName> [/DsDel] [/f]

Required. Specifies the DNS host name of the DNS server. You can also type the IP address of the DNS server. To specify the DNS server on the local computer, you can also type a period (.)
What i see you are using is the localhost,try the command with the Hostname/Full FQDN

It should work!

Hope that helps :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

WEBINAR: GDPR Implemented - Tips & Lessons Learned

Join the WatchGuard team on Thursday, March 29th as we recount some valuable lessons learned in weighing the needs of a business against the new regulatory environment, look ahead at the two months left before implementation, and help you understand the steps you can take today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now