• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 261
  • Last Modified:

Remote printer

Hi,

One of our users is working remotely via RDP.  When he connects to the network, he can use the printer in the office, but he can not use the one at home, only when he disconnect from the network, he can use it.  Is this normal?  thanks
0
mcrmg
Asked:
mcrmg
  • 4
  • 3
  • 2
  • +1
4 Solutions
 
mcrmgAuthor Commented:
he is using win 7 X64  thanks
0
 
E-Z-DSupport - AnalystCommented:
hello,

when he clicks the icon to start the rdp session (i assume windows mstsc), there's a button 'options', click that, go to local sources tab and uncheck printers. go back to first tab and save this.

the  reason for this is as followed: the printer at home would also make a connection to the remote server to which he connects (you'll see "redirected" next to it). those printers are unable to print.
0
 
mcrmgAuthor Commented:
I just spoke to him, my mistake, he is not using RDP, he is using sonicwall's netextender.  

sorry...
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
Pradeep DubeyConsultantCommented:
Check the below settings while taking RDP to the home machine :

Select option "Options" when you start MSTSC
RDP
Then make sure printer is selected for printing :
RDP settings
This is a default settings so uncheck this printer settings while taking RDP other than home machine.
0
 
E-Z-DSupport - AnalystCommented:
Hello again,

there should be a similar setting in this program, unfortunately i don't have any experience with that one. please check if there's a setting and let us know.
0
 
carlmdCommented:
On the Sonciwall, under SSLVPN -> Client Routes, make sure that "Tunnel All Mode" is Disabled. If not it will force all traffic over the VPN connection.
0
 
mcrmgAuthor Commented:
Hi,

We are using SSL-VPN, so I direct all VPN traffic to sonicwall vpn, here is the screenshot , I did have mode disabled.  thanks
Untitled.jpg
0
 
carlmdCommented:
I am assuming that the end user is first connecting the SSLVPN, then using RDP. If this is true, then I would check the RDP setup as in 39274585 above.

Another possibility is the ip address assigned by the SSLVPN (under SSLVPN -> Client Settings), verses what the user has assigned to a lan at home (if any).

For example, if you use 192.168.1.x for the SSLVPN, and the remote user has used the same ip address range for their lan at home, that is the issue.
0
 
mcrmgAuthor Commented:
He uses SSLVON connect to shared drive on our server only, and use his own application to open up files, no RDP, he does not have a pc in the office.  (I am sorry that I used the wrong term in the previous posts)
0
 
carlmdCommented:
Then I would check the ip addresses involved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now