• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 535
  • Last Modified:

Intermittent time sync error on domain computers

I'm having a problem where domain members are getting errors to the effect that synchronisation between the domain time server and the client has failed and they're unable to access network drivers - if they leave the computer be for 30 mins or so the problem appears to resolve itself but not always.  Also, if it run the net time command it displays the time which matches exactly with that displayed on the problem computer - the problem is intermittent and happening to about 15 of the 30 computers on the domain.

Domain controller - Windows 2000 Server
Member Servers - Win2k3 and Win2k8

Any suggestions please?  If you require further info please let me know.
2 Solutions
Jim P.Commented:
Create a batch job at login for all machines via GP or some script. It doesn't really matter. Yo just want to get all the non PDC's in the domain. Even the BDC's need the synch.

net time /domain:DomainName /rtsdomain:DomainName /set
net time  /querysntp/setsntp:PDCName/

Open in new window

Then afterward have a scheduled task to that runs:

Open in new window

running on a regular basis.
Make sure the clients are syncing with a domain controller.
t38Author Commented:
Thanks, I'll try the batch job and will report back.
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

SandeshdubeySenior Server EngineerCommented:
I would recommend to first check that authorative time server pararmeter is set correctly on PDC role holder server.http://support.microsoft.com/kb/816042

If any time GPO is deployed for server and client remove the same as it is not required and can cause conflict.By default domain cleints and member server follow domain hierarcy for time sync.http://support.microsoft.com/kb/223184

If the DC is configured on virtual env then you need to disable the time sync from host to VM.Refer below link to disable the same
Virtualizing Domain Controllers and the Windows Time Service

Also if there is any third party software install on DC for time sync remove the same as this could cause conflicts.

Please also make sure that udp port 123 which as direction the chosen NTP server is not blocked.

Hope this helps
More basically I would recommend to disable the Windows built in time service W32time - a thing  that I had a lot of hassle with - and use the classic NTP service. See this article for more info.

The script method mentioned above is nice, but it results in hard time steps on the machines running it. Some software might react unpredictable especially on hard steps that go into the past (aka stepping back a computer whose clock is running too fast).

The NTP service acts much nicer by permanently tuning the system clock frequency to get the system clock in sync with the time master and keep it in sync.
t38Author Commented:
Thanks for your input - the batch fixed the problem but it's good to know re. W32time...
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now