Mixed Content Warnings on Sharepoint 2010 thru UAG

We publish sharepoint 2010 sites through forefront UAG. Some of our sites have external content (google maps, weather, etc) especially our MySites. Obviously, through UAG these sites are getting mixed content warnings.

Is there a way to force UAG to SSL everything when it passes through? Even the external stuff?

Who is Participating?
nodemasterConnect With a Mentor Commented:
I have had the same issue in the past with non-SharePoint websites. The solution for me was to hard-code the external links using "https://..."
I know Google content can be accessed via SSL...as well as AccuWeather and Weather.gov (Nation Weather Service).
mis-Author Commented:
yeah, I knew that was an option. I think some of the content doesnt have https though. I was hoping there was something you could do in UAG.

I guess we may just have to remove the content that doesnt have an https link...

If we did hard code everything to https.... would we get mixed content warnings from our internal users? They just connect via http to the sharepoint server and bypass UAG.
If your internal users are on an Active Directory domain, you can suppress the warning via a Group Policy. You can add the URL to either their Intranet Sites or Trusted Sites zone, then set "Display mixed content" to "Enable" for that zone.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.