Access 2010 "ODBC--call failed" in the linked table manager

I am using Windows 7 64bit/MS Access  2010 and a SQL server backend

I can connect to the Server using ODBC (64 bit) but when using the linked table manager to do a relink with "Always prompt for new location" selected I always get the error ODB--call failed

I also know on 64 bit Windows there are two versions of ODBC Administrator Windows the 64bit you can access through the Control Panel which is where I added the User data source for ODBC.

Any Suggestions?
BrogrimInformation Systems Development ManagerAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Jim Dettman (Microsoft MVP/ EE MVE)Connect With a Mentor PresidentCommented:
OK.  So:

1. DSN=DDAI - Can you get a sucessfull test from the ODBC applet in control panel on this DSN?

2. "SERVER=xx.xx.xxx.xxx;DATABASE=ddai;PORT=3306"  are these correct?

3. Which version of *Access* (Office) are you using; 32 or 64 bit?  This is what determines which version of the ODBC admin applet you need to use (64 bit is the one through control panel, 32 bit is in C:\Windows\SysWoW64).

Jim.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Try setting up a DSN through control panel (which is the 64 bit version) as a system DSN.

Then try creating a linked table using that DSN.   I think if you do that, you'll discover your problem.

The other thing that would help is if you posted the connect string that you have right now.  Open Acccess, then do alt/F11 to bring up VBA, then Ctrl/G to get the debug window.

Type

?  CurrentDB().Tabledefs("somelinkedtablenamehere").Connect

Jim.
0
 
BrogrimInformation Systems Development ManagerAuthor Commented:
Hi Jim,

Connection String:

ODBC;DSN=DDAI;SERVER=xx.xx.xxx.xxx;DATABASE=ddai;PORT=3306;DFLT_BIGINT_BIND_STR=1

I am going to be away from the PC for a couple of hours will
most reply tomorrow morning

Thank.
0
 
BrogrimInformation Systems Development ManagerAuthor Commented:
Hey Jim,
The issue was that I was using 32 bit Access so once I added ODBC from the SysWoW64 folder it worked.

Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.