Thunderbird Email. Switch from local Postfix server to GoDaddy server. Old mailbox is still getting email.

We were using a Linux PostFix email server for an internal mail server.  It had been working fine but recently started acting weird when we were trying to connect with some iPhones.  Sometimes they would work and other times it would say server unavailable.  Tried multiple things to fix with no solution.  We finally decided to switch off the PostFix server and go to GoDaddy.  All of the users use Thunderbird for the email client.  On each machine a new account was created to attach to the GoDaddy email.  The old account was left so the user could still access old emails if necessary.  The problem is the old inbox still gets email from all the local users.  That I can find, there is no way to disable this account while still giving them access to their old email.  I tried changing the account settings on the old email account to point to a server that did not exist.  Strangely, when you sent an email using the new GoDaddy account, Thuderbird wanted to save the sent mail in the old accounts sent mail folder.  This even happened when the GoDaddy account was set to the default account.  I am looking for a way to get the system to understand that the new GoDaddy account is the primary default account and not to use the old account for anything.  Does anyone have any ideas how this can be accomplished.  Any help is greatly appreciated.
kwh3856Asked:
Who is Participating?
 
Jan SpringerConnect With a Mentor Commented:
They have changed their MX record to point to a non-local server.

If the local users relay mail through the local server and the local server is configured to accept delivery for users of the local domain then mail will not get delivered to the new MX.

That's how MTAs work.
0
 
Jan SpringerCommented:
You have to go into your Postfix configuration and remove your domain name as having local delivery and restart Postfix.
0
 
kwh3856Author Commented:
What option should I change?
PostFix.jpg
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
Jan SpringerConnect With a Mentor Commented:
I am not familiar with Webmin.  You need to change the "mydestination" variable in /etc/postfix/main.cf
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
Try deleting the old SMTP [Postfix IP] on the local PC of the user in Thunderbird. Then create a new SMTP that points to GoDaddy.
0
 
Jan SpringerCommented:
If that's all that the author does, then local mail is going to be missed.  S/he needs mail from local clients to be delivered to the correct MX destination.  And that's only going to happen if a different outbound SMTP server is used or the current local server is properly updated to not accept mail for that domain.
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
I actually thought they want to move away from local Postfix.

....:)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.