Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Issue with having www in url for wordpress installation

Posted on 2013-06-25
6
Medium Priority
?
277 Views
Last Modified: 2014-07-14
Hello, I have a site which uses the WP network type of installation. With that being said the site url is set to www.coloradocutthroat.com but I want to change it to coloradocutthroat.com. Currently people have to type in www.coloradocutthroat.com to get to my website instead of putting in coloradocutthroat.com. My domain on my host is setup as coloradocutthroat.com but my wordpress is forcing the www. How do I fix this on a network?
0
Comment
Question by:DancingFighterG
6 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39275975
Edit the General Settings for the WordPress installation and remove the www. from there.
0
 
LVL 15

Expert Comment

by:eemit
ID: 39276091
1)
Change this in your wp-config.php:
define('DOMAIN_CURRENT_SITE', 'www.coloradocutthroat.com');
To:
define('DOMAIN_CURRENT_SITE', 'coloradocutthroat.com');

2)
In Network Admin Dashboard
- Go to Sites > All Sites
- Locate the site
- Click on the Edit action link
- In Tab Info: remove www from Domain if it exists
- Make sure that this checkbox is checked: Update siteurl and home as well
0
 

Author Comment

by:DancingFighterG
ID: 39293713
Hello, I went through the steps but I ran into one issue. When I go to the network sites section it does not allow me to change the domain. Also I don see the the checkbox - Update siteurl and home
0
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

 

Author Comment

by:DancingFighterG
ID: 39293727
Here is a screenshot of what I see. Is the checkbox in the setting area because I don't see it there either
screen.png
0
 
LVL 15

Accepted Solution

by:
eemit earned 2000 total points
ID: 39294460
>Also I don't see the checkbox - Update siteurl and home  
Do you see the checkbox on another not the root site?

Unfortunately it looks you have to make changes in the database also.
Try to change siteurl and home options in wp_options table and in each of wp_x_options (e.g. wp_2_options ...) tables.

There is also the option named “siteurl” in the table wp_sitemeta.
0
 

Expert Comment

by:Richard Jemmett
ID: 40194508
I think that you need www - if you do not have it then Google and others will not see your site correctly. For example you need www. when adding structured data to webmaster.

I think what you need is for the user type in your domain name with or without www and still get to the website?
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to install BuddyPress on your self-hosted WordPress site It’s been called everything from “social networking in a box” to “Facebook without the terms of service,” but until Feb. 16, BuddyPress was a relatively unknown outside the WordPress MU…
WordPress is constantly evolving, and with each evolution appears to get better and better.  One of the big drawbacks prior to version 3 was that there was no way to be able to set up a custom menu from the backend. The Old Way Adding menus is…
The purpose of this video is to demonstrate how to reset a WordPress password if you are locked out and cannot reset the password. A typical use would be if you cannot access the email to which WordPress would send the password recovery email to…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…
Suggested Courses

886 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question