• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 681
  • Last Modified:

Exchange 2003 to Exchange 2010 - Cannot migrate mailboxes

I am trying to migrate from Exchange 2003 on SBS 2003 to Exchange 2010 on Server 2008 R2.  Everytime I try to move a mailbox I get this error.

I have made sure that include inheritable permissions is checked on the user.

Anyone have any ideas?



Please see diagnostic text below.

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:04


Administrator
Failed

Error:
MapiExceptionCallFailed: Unable to make connection to the server. (hr=0x80004005, ec=1283)
Diagnostic context:
    ......
    Lid: 9624    dwParam: 0x6D9      Msg: EEInfo: Detection location: 501
    Lid: 13720   dwParam: 0x6D9      Msg: EEInfo: Flags: 0
    Lid: 11672   dwParam: 0x6D9      Msg: EEInfo: NumberOfParameters: 4
    Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[0]: Unicode string: ncacn_ip_tcp
    Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[1]: Unicode string: gmhs-srv-2-01.gmhs.local
    Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[2]: Long val: -545057711
    Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[3]: Long val: 382312662
    Lid: 45169   StoreEc: 0x824    
    Lid: 44273  
    Lid: 59431   EMSMDB.EcDoConnectEx called [length=117]
    Lid: 34855   EMSMDB.EcDoConnectEx returned [ec=0x503][length=56][latency=15]
    Lid: 59505   StoreEc: 0x503    
    Lid: 52465   StoreEc: 0x503    
    Lid: 60065  
    Lid: 33777   StoreEc: 0x503    
    Lid: 59805  
    Lid: 52209   StoreEc: 0x503    
    Lid: 56583  
    Lid: 52487   StoreEc: 0x503    
    Lid: 19778  
    Lid: 27970   StoreEc: 0x503    
    Lid: 17730  
    Lid: 25922   StoreEc: 0x503    

Warning:
When an item can't be read from the source database or it can't be written to the destination database, it will be considered corrupted. By specifying a non-zero BadItemLimit, you are requesting that Exchange not copy such items to the destination mailbox. At move completion, these corrupted items won't be available in the destination mailbox.
0
considerscs
Asked:
considerscs
  • 8
  • 7
1 Solution
 
AmitIT ArchitectCommented:
Is this for all users or one mailbox.
0
 
considerscsAuthor Commented:
all users that I have tried so far.
0
 
Alan HardistyCommented:
If you have a Firewall on the SBS 2003 Server or Windows 2008 R2 server, please disable it and try again - that may include ISA server or 3rd party AV software as some have Firewalls built in which can hamper communications.

Alan
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
considerscsAuthor Commented:
firewalls are off by default in my domain.  I push a policy to disable them, plus disabled them when building the server.

I have double checked them also and they are not on.

No antivirus exists on these servers nor do i have any third party firewall servers.
0
 
Alan HardistyCommented:
Okay - what Authentication methods do you have enabled on the Default SMTP Virtual Server on the SBS server?  You need all 3 enabled.
0
 
considerscsAuthor Commented:
Anonymous access checked - resolve anonymous email not checked
Basic authentication checked - requires TLS encryption not checked
Integrated Windows Authentication checked.

I am trying to decommission this badly built SBS 2003 box.  I have done many 2003 to 2010 and have never had this many issues with a migration.
0
 
Alan HardistyCommented:
0
 
considerscsAuthor Commented:
Yes i have even stopped and restarted it a couple times thinking it was the issue and it was not.
0
 
considerscsAuthor Commented:
i have also created a box on the 2010 exchange and tried to reverse migrate it to 2003 and that does not work either.  Same error.
0
 
Alan HardistyCommented:
Can you ping the NETBIOS name of the SBS server from the 2008 server and vice-versa?
0
 
considerscsAuthor Commented:
yes can ping back and forth no problem.  I can do anything across the servers I need to besides get the exchanges to talk.
0
 
Alan HardistyCommented:
Did the Routing Group Connector get created?
0
 
considerscsAuthor Commented:
I have one that is showing on both servers and it is a routing group between the two servers.

But on each server looking at the routing group connector, it only shows itself in the connector.
0
 
Alan HardistyCommented:
Okay - sounds fine.

Can you reboot both servers please and try the move again.
0
 
considerscsAuthor Commented:
ok that worked.  I migrated a box with no issues.

Weird thing is i have rebooted twice before that and same error.  I didnt make any changes either since the last reboot.

Thanks for all the help.
0
 
Alan HardistyCommented:
The Inherited permissions (if you applied them) can take a couple of hours to take effect, but either way, glad you are working now.

Alan
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now