• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 534
  • Last Modified:

VM going to "sleep"

I have a virtual PC (VPC) running Windows 7. If i log into the VPC through the vSphere client it works fine. If i try to log in using RDC i get:

RDC Cannot connect bc of one of the following:

1) RDC not enabled
2) Remote computer turned off
3) Remote computer not available on the network

None of these conditions is true.

Why would the VPC not be available
0
mikesiegel
Asked:
mikesiegel
3 Solutions
 
TunerMLSystems EngineerCommented:
Is RDS enabled and allowed through the firewall? Have you tried using the IP instead of computer name? are you able to communicate with this PC in any other way can you for example ping the machine?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
try telnet <ip address of machine> 3389 ?

respond Remote Desktop Connection - ENABLED, no response, Remote Desktop Connection DISABLED or BLOCKED!

if the VM is going to sleep and turning off, and they can do, go to a Suspend State

Disable Power Management in the VM.
0
 
LCCSAMCommented:
Have you tried turning off "Hybrid Sleep Mode"? (instructions can be found here INSTRUCTIONS )
I use this method on a PC which I connect to through RDP exclusively.

(This PC is on 24/7 however so turning off this mode may increase energy usage!)
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Paul SolovyovskySenior IT AdvisorCommented:
Most likely power management in the VM is turned on.  Turn off power management and that may resolve the issue
0
 
mikesiegelAuthor Commented:
how do you disable power management in the VM
0
 
Paul SolovyovskySenior IT AdvisorCommented:
same way you do it in a physical machine.  Essentially the VM is going to hibernate and there is no virtual power button you can press to get it out of it easily.  Go to control panel and go to power options and disable screen and hard drive shut down
0
 
mikesiegelAuthor Commented:
thanks but the previous solutions solved it for me
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now