Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 738
  • Last Modified:

How to enable hibernation mode in Fedora 18?

HI

I have a laptop with Linux Fedora 18 and when I click on the User Menu there are only two options, Block the computer and Shutdown but there isn't any option for hibernate, how to enable it?

Thanks.
0
dimensionav
Asked:
dimensionav
2 Solutions
 
MazdajaiCommented:
f1 removed the hibernate option for gnome, try install this extension -
https://extensions.gnome.org/extension/14/shut-down-menu
0
 
xeroxzeroxCommented:
Two method below given....

1. To activate hibernation,
you have to enable the dconf option in /org/gnome/shell/extensions/alternative-status-menu/allow-hibernate. Either in dconf-editor or via the command line: dconf write /org/gnome/shell/extensions/alternative-status-menu/allow-hibernate true

2nd method

To have back the hibernate.
Go in .local/share/gnome-shell/extensions pay attention at the dot before local, is a hidden directory.
Enter in directory named alternative-status-menu Open with gedit the file extension.js
The line 28 is this item.actor.visible = object.get_can_hibernate() && settings.get_boolean('allow-hibernate');
change it in this item.actor.visible = object.get_can_hibernate(); for some strange reason in the config file *.gschema.xml the hibernate is set to false and Change it to true, but you  remove the control of the option.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now