Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1439
  • Last Modified:

Can't Delete Messages in OWA- Out of Ideas

For three weeks now, our users have not been able to delete from OWA - that is by right-clicking on a message and deleting but if they double-click on it and go into it, they can delete it.  Also, they can delete fine from OWA Light.  Believe it or not, I have been working daily with Microsoft on this for two weeks and I have gone through 8 different techs there.

Here is our setup:
2 CAS servers, 2 DAG servers - Exchange 2010 SP2 - Rollup 5
While working with Microsoft, I have ran every diagnostic, monitoring and logging tool known to them and sent them dozens of log files.  
The Microsoft Tech even went as far as to re-install Exchange on one of the CAS servers, essentially removing and re-installing the CAS role and after he finished, I changed my host file on my pc to point to that server and we still encountered the same issue.
We have done pretty much everything I have read while researching:
1. Deleted or Renamed the Web.config files
2. Deleted and Recreated the WebServicesVirtualDirectories
3. Removed and Re-established the bindings in IIS
4. Verified redirection in IIS
5. Rebooted and Reset IIS I don't know how many times.

When we try to delete in OWA, two things happen:
1. The user sees the following message: The Action you tried to perform couldn't be completed because there's a configuration problem on the server
2. Event ID 108 shows up on the CAS server- basically repeating the message above.
3. I checked for Custom Host Headers in IIS and we don't have any.

Microsoft suspects a binding issue in IIS due to the fact that we cannot browse our localhost or local IP on the CAS servers -- In IE, however, I installed Chrome and we can do it there?

Anyhow, they are now leaning towards formatting our two CAS servers and 2 Dag servers and starting over.  That is not something we want to do.


Any ideas?
0
AnchITSupport
Asked:
AnchITSupport
1 Solution
 
James HodgeManaging DirectorCommented:
Hello,

Try the following:

Make a backup of file web.config in c:\inetpub\wwwroot
Open the original web.config file (with notepad)
Search for childonly="false" and replace th "false" with "true" - then save the file
Restart the IIS Services (iisreset)

James
0
 
Malli BoppeCommented:
Have you tried  to reset the Virtual directories to the default on both the CAS servers.
0
 
R--RCommented:
First take a backup of iis.

Check this
EWS only Anonymous and Windows Authentication are enabled. Removed the hostname from default web site. Restarted IIS.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
AnchITSupportAuthor Commented:
Hi:
Thanks for responding.  
I have already looked for the Child entry in the web.config but I couldn't find it.  I will check that again.

I didn't reset the virtual directories to the default on both servers.  After resetting it on CAS1, (and IISRESET) I changed my local host file to point to CAS1 for https://outlook.xxxx.ca
and it still did not work.  As part of that test, I also stopped CAS2 as a host in Windows NLB which forced clients to only CAS1 and it still did not work.  Also, as I mentioned, we also re-installed Exchange on the one CAS server and that would have reset those directories as well.  I am hoping to test with one CAS Server in case something gets messed up.

I didn't have any host names on the default website and I had Anonymous and Windows Auth for EWS and I even added Basic as a test.  Microsoft went through all of the permissions, trying different things.
I would love to be able to figure this out before Microsoft because it has been a stressful ordeal.  The continue to say that it is our network.
I noticed last night that we can also right-click on a message and choose "ignore conversation" and that deletes it.
0
 
Simon Butler (Sembee)ConsultantCommented:
The first thing I would have done is install Exchange 2010 SP3. I find that resolves a lot of issues, as it effectively reinstalls the product.

Simon.
0
 
AnchITSupportAuthor Commented:
Thanks Simon.  I am thinking that we might do that but if the problem is IIS, I am not sure if that will do it because I believe the SP would still leave IIS in tact as far as the config.  Anyhow, we don't have much choice at this point.
0
 
AnchITSupportAuthor Commented:
The problem has been solved after working with Microsoft for 3 weeks.

I don't know why this happened but in the registry:

HKLM-System-CurrentControlSet-Control-SecurityProviders\SCHANNEL\Protocols\:
We had:  SSL 1.0, SSL 2.0, TLS 1.0 and PCT 1.0, or something to that effect.  As soon as we removed everything but SSL 2.0, we were able to Delete in Owa and Browse the LocalHost.
Even in SSL 2.0, there was a client and a server subfolder and we also deleted the Server folder.
Very strange.  After we made the change, we didn't have to reboot or restart any service.  It just started working.

This may not happen to anyone but in the case where you have tried everything else, please look to see of those keys are in the registry.
0
 
AnchITSupportAuthor Commented:
The issue has been resolved.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now