Solved

SBS2008 backup - Microsoft Block Level Backup Engine Service EXE has stopped working

Posted on 2013-06-25
12
3,600 Views
Last Modified: 2016-03-20
Having just taken over the IT for this particular client, we are unable to start the SBS backup from the SBS console.

In SBS Console > Backup
"Last Backup", "Status" and "Next Backup" all show "Unknown".

I have just restarted the server and noted the following message appearing:
"Microsoft Block Level Backup Engine Server EXE has stopped working".

This message is also appearing when trying to "Configure server backup" in the SBS console.
-------------------------------

Other backups that are running:

We use JustCloud to send data off-premise.  This data includes files only (no databases, exchange etc.)
We are also using Mozy Pro to send data off-premise.  This data includes files only (no databases, exchange etc.)
We use managed anti-virus (managed via GFI remote management)

Regarding the points about JustCloud and Mozy above, we have tried to run the backup whilst these are disabled but the result is the same.

-------------------------------
-------------------------------

Error Messages

Regarding error messages - there is a lot of them.  I'm hoping the ones added below might help:

Error 1000 - (100):
Faulting application wbengine.exe, version 6.0.6002.18005, time stamp 0x49e023c7, faulting module wbengine.exe, version 6.0.6002.18005, time stamp 0x49e023c7, exception code 0xc0000005, fault offset 0x000000000003eca4, process id 0x330, application start time 0x01ce71719e20c80f.

Error 2424 - Gatherer:
The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again.

Context: Application 'Search', Catalog 'index file on the search server Search'

Error 1008 - Perflib:
The Open Procedure for service "BITS" in DLL "C:\Windows\system32\bitsperf.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code.
-------------------------------
Help is appreciated.

Regards,
Matt
0
Comment
Question by:azuz_it
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
12 Comments
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39277433
Check if this hotfix helps

http://support.microsoft.com/kb/981851
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39277435
Also i want you to refer below link, where same problem is reported and it got fixed after
removing  "Mobiel Internet Software" package from KPN Mobile"

http://social.technet.microsoft.com/Forums/windowsserver/en-US/fb353f1d-afdd-43ac-8898-aeb30bde86db/windows-server-backup-fails-microsoft-block-level-backup-engine-service-exe-stopped-working-and
0
 

Author Comment

by:azuz_it
ID: 39277449
Hi,
Thanks for the feedback.
I tried the hotfix but receive "The update does not apply to your system" when trying to install.

We don't have the software mentioned above installed on the server.

For information I am also receiving:
"The wizard cannot retrieve backup settings"

Regards,
Matt
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39277478
Alright download

Windows Small Business Server 2008 Best Practices Analyzer

http://www.microsoft.com/en-us/download/details.aspx?id=6231

and check if it gives any  additional information.
0
 

Author Comment

by:azuz_it
ID: 39277487
Hi,
We have that installed.  I ran this and it came back with one (presumably unrelated) critical issue):

DNS A resource record points to incorrect IP address:
The host (A) resource record points to the incorrect IP address 192.168.6.11192.168.6.57. The record should point to 192.168.6.11.

Regards,
Matt
0
 
LVL 11

Expert Comment

by:Sanjay Santoki
ID: 39286504
Hello,

In respect of DNS records; if your server is configured for only one IP address remove other IP address from the DNS zone from DNS management console.

For backup, please make sure that other backup software has not disabled VSS or something..

Regards,
Sanjay Santoki
0
 

Author Comment

by:azuz_it
ID: 39288558
Hi Sanjay,
I have checked the services and shadow copy is running.

I have closed the Mozy application and will let the backup run as scheduled this evening (I started an initial backup and it seemed to be running ok).

I'll update when I have more info.

Regards,
Matt
0
 

Author Comment

by:azuz_it
ID: 39301310
Still not working.

Completed following tests:
vssadmin list writers: all Stable / No error
Uinstalled Core FTP, FileZilla and Imgburn
Ran Backup and Server Storage > Backup > Configure server backup and received message "The wizard cannot retrieve backup settings. An unknown problem is preventing the wizard from retrieving backup settings."

Followed http://support.microsoft.com/kb/2001010
Backed up file and registry to C:/Backup/2013-07-05 - Backup issue
This did not fix the issue.

Ran the backup once wizard from Windows Server Backup and it told me that I have no valid backup destinations (although I can see this in disk management and it does not have a drive letter).

Ran backup schedule and I get an error "The windows server backup service has stopped".
0
 

Accepted Solution

by:
azuz_it earned 0 total points
ID: 39315308
Please note - I have resolved this issue myself.  Here are the steps to resolution and suggested walk-through:

Add new admin account, log off and in as new admin user.  This will test whether this issue was caused by a corrupt profile.
In my case, this did not resolve the issue.
------
Completed the following in an elevated command prompt:
(Note that this may delete any previous shadow copies).

Cd windows\system32
Net stop vss
Net stop swprv
regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
regsvr32 /i swprv.dll
regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
regsvr32 vssui.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll
regsvr32 msxml4.dll

In my case, some registered, some showed "The module "x.dll" was loaded but the entry-point DllRegisterServer was not found.  Make sure that "x.dll" is a valid DLL or OCX file and then try again."
---
Try to configure backup from the SBS console and run backup.
In my case a full backup completed successfully.
0
 

Author Closing Comment

by:azuz_it
ID: 39326005
Experts advice did not help with this issue.  Further troubleshooting by myself resolved the issue.
0
Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question