Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


Adding Server 2012 Domain Controller to Existing 2003 Domain

Posted on 2013-06-26
Medium Priority
Last Modified: 2014-07-21
I have a single server 2003 32bit domain controller not R2.  I am trying to add a second domain controller with Server 2012 with a view to retiring the first 2003 domain controller.

I am getting these errors when I try to add the new server as a DC.

Adprep could not retrieve data from the server myserver.mydomain.co.uk through Windows Managment Instrumentation (WMI).
[User Action]
Check the log file ADPrep.log in the C:\Windows\debug\adprep\logs\20130624171731-test directory for possible cause of failure.

Adprep encountered a Win32 error.
Error code: 0x5 Error message: Access is denied.

Adprep failed while performing Exchange schema check.
The Active Directory Domain Services schema is not upgraded.
[User Action]
Check the log file ADPrep.log in the C:\Windows\debug\adprep\logs\20130624171731-test directory for possible cause of failure.

Adprep encountered a Win32 error.
Error code: 0x5 Error message: Access is denied.

I have tried these fixes but no success...

Question by:jongrew
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39277362
have you run adprep from command line with "run as" permission?

Author Comment

ID: 39278439
On which machine should this be run.  There is no 32bit adprep available for server 2012 to run it on the server 2003
LVL 15

Expert Comment

by:Rob Stone
ID: 39279215
Have a flick through this MS link on troubleshooting ADPrep errors.


2012 automatically finds the Schema Master so you don't have to run adprep from that specific box (generally speaking!).  That said, I've only tested that in a domain running 2008 R2 (64bit) so whether that works with 2003 32bit I can't confirm.
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

LVL 13

Expert Comment

ID: 39281048
check the below link it may help you


Accepted Solution

jongrew earned 0 total points
ID: 39283693

None of these things helped I'm afraid.  I have now resolved the Server 2012 DC Promo issue by adding a virtual server with Server 2008R2 and transferred all the FSMO roles across to this server and then running the Domain Controller Promotion Wizard on the Server 2012 with success at last.  I shall now transfer the FSMO roles to the Server 2012 machine and then demote the 2003 server and then finally the Server2008 virtual server.  I'll keep you posted how it goes...

Author Comment

ID: 39296431
I have completed the task

The old server is now demoted and gone and the intermediate 20008R2 server is now demoted and gone leaving me with just the server 2012 DC.

Thanks for your input though everyone.

Author Closing Comment

ID: 39306581
No other suggestions worked and I don't believe now it could have worked after looking at more and more articles I found on the subject

Expert Comment

ID: 39355787
This happened to me, I was able to fix by going into Component Services on 2003 server, right click 'my computer', properties, on 'default properties' tab 'enable distributed COM on this computer' was unchecked.  I checked it and reboot both servers, I was then able to promote the 2012 server to DC, adprep went thru with no issues.

Hope this helps someone else, I was not able to find this fix from MS or any google search... had to run wmidiag.exe which showed dcom disabled on 2003.

Author Comment

ID: 39355865
SBSDan: Thanks for that comment.  I'll bear that in mind for next time I have the same scenario, it certainly would have saved me time.

Expert Comment

ID: 39773582
SBSDan:  Worked like a charm.   Thank you!

Expert Comment

ID: 40210623
The answer to this is found here. http://www.kickassnetwork.net/?p=431 WMI is the issue. Follow the WMI guidelines and once repaired, promotion is straightforward. I hope I save someone the hours it took me to find this.

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
Resolve DNS query failed errors for Exchange
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question