Help installing Powerchute onto ESXi Server

Hi

I am running ESXi - HP-ESXi-5.1.0-standard
I want to install Powerchute Agent

As per the instructions I have created a CD with the files on and inserted this into the server.

I SSH to the server and follow the instructions:

-mkdir /mnt/cdrom
-mount /dev/cdrom /mnt/cdrom

Fails at this step already: mount: not found

So, trying to be clever, I uploaded the files onto a Datastore and browse to that instead:

cd /vmfs/volumes/datastore01/Linux

I then try to execute the script:

-sh install_pbeagent_linux.sh

The script starts, but as soon as I choose connectivity method on the first screen I get:

Installing PowerChute Business Edition Agent .....
PowerChute Business Edition Agent could not be installed, RPM failed.
Please check PowerChute Business Edition Agent is not already installed.
/vmfs/volumes/512f8aa8-111fee21-e441-1cc1de6f571c/Linux #

What shall I do?
bikerhongAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
This needs to be completed on the vMA

http://www.vmware.com/support/developer/vima/

APC PowerChute software is installed on vSphere Management Assistant appliance.

See here for instructions and manual

http://www2.schneider-electric.com/resources/sites/SCHNEIDER_ELECTRIC/content/live/FAQS/165000/FA165747/en_US/Configuring%20ESXi.pdf
0
 
bikerhongAuthor Commented:
Am I being thick here!

I have deployed vMA and I am trying to WinSCP the files to it.

However the vi-admin account keeps saying access denied, even though it works when logging onto the console?!
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
so you cannot login via ssh with vi-admin?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
bikerhongAuthor Commented:
It was the password. I think becuase there were a lot of symbols, maybe the keyboard mappings for the console and local PC were different.

I simplified the password a little and it was fine
0
 
bikerhongAuthor Commented:
Now I have it all set up as per the document, is that it?

Or do I still need to install the PowerChute Server/Console and do more configuration?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you have followed the document, you are done.
0
 
bikerhongAuthor Commented:
Grrr, says unable to comminicate on the port I selected.  

Is there anyway I can change it without having to uninstall and reinstall?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.