The PC that will not ping

Network Admin checking in.  I have a coworkers computer that simply will not allow an incoming ping or push of software.  

Windows 7.  Microsoft Security Essentials for AV.  IPv6 Disabled.

It's as if the firewall is running... but it's definitely disabled.  It can ping out and get responses just fine.  But from other PC's or networking gear I cannot get to it.  There is no networking gear in the way.

Windows firewall, defender, MSE are all disabled.  I've tried stopping most all unnecessary software.  Tried resetting winsock.  Tried setting a static IP to make sure he didn't have a duplicate IP.

Any other bright ideas?

thanks
admineoAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
admineoConnect With a Mentor Author Commented:
Fixed.  There were some corrupt registry keys involving the Windows Firewall.  His account, even though he is admin, lost access to the keys/services.  What's odd... is that it must have been running... but no where did it indicate that it was?

There is a Microsoft FixIt that corrects the issue.  What led me down this path was trying to enable the Windows Firewall service, and got a permissions error.

Here is all of the pertinent info:

http://answers.microsoft.com/en-us/windows/forum/windows_7-security/cannot-start-windows-7-firewall-get-error/754bba1e-d100-45b2-8a2e-91ed41af61e3

http://support.microsoft.com/kb/943996/en-us?wa=wsignin1.0

I am giving Pradeep partial credit as he suggested I try to get the firewall running.
0
 
Pradeep DubeyConsultantCommented:
In some cases, ping requests fail. This happens for any of several reasons:
the IP address specified to the ping program is invalid
the host system (device being used to send pings) is not connected to an IP network (i.e., does not have a working IP address)
no network device is connected to the target IP address
network congestion or errors in between the host and target are preventing messages from passing through (in one or both directions)

http://compnetworking.about.com/od/workingwithipaddresses/ss/how-to-ping-the-ip-address-of-a-computer_2.htm


Below is the answer
http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-to-enable-ping-response-in-windows-7/5aff5f8d-f138-4c9a-8646-5b3a99f1cae6
0
 
pjamCommented:
Other programs have firewalls included.  Does he have an nVidia graphics card, some drivers included a firewall. Dumb  know.
Also AT&T global Network client for accessing a VPN can have a firewall turned on.

Just a thought
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
admineoAuthor Commented:
@pradeep08_81 - That would be a good answer - if the firewall were enabled.
0
 
admineoAuthor Commented:
@pjam - No NVidia software, no AT&T software.  I've tried stopping a whole bunch of services.  Tried logging in as local administrator account.  I'm baffled...
0
 
admineoAuthor Commented:
Update: Does not ping in 'Safe mode w/ Networking' either.  Is it a hardware/NIC setting?
0
 
Pradeep DubeyConnect With a Mentor ConsultantCommented:
Do one thing enable the firewall and change the ping settings then try with ping and after that disable the firewall and ping the machine.

Do this test once.
0
 
Pradeep DubeyConsultantCommented:
Also did you make below changes which is already listed in the given link:

Ping: this is reply by the machine on the network when request is sent to this machine's IP address. Why it is necessary: suppose you have multiple machines and you want to know if there is machine on the network with given IP. That's when you use ping. This packet is classified as ICMP (Internet Control Message Protocol). Many network admins routinely use that and windows machines are their pain as these by default do not respond ping (MS must be scared since infamous "Ping of death"...).

Anyway, here is how I enabled ping response in Windows 7:

Control Panel --> System and security --> Windows Firewall --> Advanced settings --> Inbound rules --> New rule --> custom rule

in Protocol and ports: Protocol: ICMPv4
on the same panel go to customize, choose "Specific ICMP types", check the box "echo request"

The rest is trivial; go to next... next... and save it.

You should be done. This box responds ping from this point on.
0
 
QlemoConnect With a Mentor Batchelor, Developer and EE Topic AdvisorCommented:
"Disable Firewall" does not mean "Disable Firewall Service" - as the latter has some strange effects sometimes. Just to make sure we are on the same page ...
0
 
admineoAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for admineo's comment #a39278653
Assisted answer: 250 points for pradeep08_81's comment #a39278591

for the following reason:

Pradeep pointed me in the direction - but I resolved the issue myself.
0
 
Pradeep DubeyConsultantCommented:
Admineo, Thanks for the credit.

I have notice this in my test lab some time when firewall service even stopped ping also stopped.

I started the firewall and ping from outside it started working. So suggested you this.  :-)
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Isn't that what I described in short in http:#a39278594 ?
0
 
Pradeep DubeyConsultantCommented:
@Qlemo read the post again from start to end and have you read the provided link in my previous post ? seems NO as in the said post i have already written "which is already listed in the given link:"

the link was :

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-to-enable-ping-response-in-windows-7/5aff5f8d-f138-4c9a-8646-5b3a99f1cae6


Is this not indicating i have already given link for the same?
I have given link and i thought he didn't read that so i copy past some part of the link.


I know copy past is not allowed without link in EE.
0
 
Pradeep DubeyConsultantCommented:
I know summarizing the things but if you are posting the content from the link then it does not needed any summary not in my worlds.

Thanks for clarifications.
0
 
admineoAuthor Commented:
Oops.  I could have sworn I selected ID: 39278549 and not ID: 39278591.  For that I apologize.  I agree that ID: 39278591 was not the answer.  That being said, ID: 39278549 was the partial answer that pointed me in the right direction.

Your (@Qlemo) comment, ID: 39278594, was really more of a statement than a solution.  Absolutely a valid statement, though.  I'm just going to split up the points to stop the whining and bring some closure.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.