Solved

ExFolders

Posted on 2013-06-26
6
564 Views
Last Modified: 2013-10-18
I am trying to use ExFolders against 2010 and I select the GC and then select the stores.  I then select the folder properties I am trying to find and I get an error that the user does not have permission to access the mailbox.
even though the user I am logged in as is the domain admin for all servers.

Any thoughts?

If not have any thoughts on how to find a file that is causing a DOC_TOO_HUGE error in the stores?
0
Comment
Question by:Liam Dwyer
6 Comments
 
LVL 42

Expert Comment

by:Amit
ID: 39278783
Domain admin doesn't have access to Exchange mailbox database. You need to add permission at DB or Mailbox level and access. Also it is recommended not to use domain admin users for supporting Exchange server. You should rather create new account and add it to Exchange Org Group.
0
 

Author Comment

by:Liam Dwyer
ID: 39278822
Thank you! And I am assuming that I can only do that in ADSI or powershell?
It is one domain admin user set for all servers.  Not my environment not set up by me.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39278840
I would create another account to do this work, rather than using the Domain Admin. That will allow you to have some control and accountability. The permissions have to be set via EMS:

This will give the account permissions to list the mailboxes:
Add-RoleGroupMember "View-Only Organization Management" -Member "MailboxAdmin"

and this will give them permissions to access them:

Get-MailboxDatabase | Add-ADPermission -User "MailboxAdmin" -AccessRights ExtendedRight -ExtendedRights Receive-As, ms-Exch-Store-Admin

Receive As is the same as Full Mailbox Access.

Simon.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 42

Expert Comment

by:Amit
ID: 39278848
Powershell is required to setup the permission. You can use the command posted by Simon above.
0
 

Author Comment

by:Liam Dwyer
ID: 39278866
Thanks guys! I will do some work tonight.
0
 
LVL 1

Accepted Solution

by:
guru-di-exchange earned 500 total points
ID: 39408546
Hi Liam, Run the following shell command and you will set the permissions on all the mailboxes in your organization so that the user you specify will have FullAccess rights on all mailboxes and ExFolders will not throw that error out anymore:

Get-Mailbox | Add-MailboxPermission -User [username] -AccessRights FullAccess –InheritanceType All

Hope this helps.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video discusses moving either the default database or any database to a new volume.

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question