Running Excel 2003 and 2010 - issues

I need to have Excel 2003 on my machine for an occasional work around for certain older xls files.  I have Office 2010 as my main office suite.  I was able to just install Excel 2003 by itself (in a separate folder) and after I installed it, I had to do a repair on office 2010 for it to go back to being the default.  However, my problem is this:  When I open up a file with .xls extention, it opens with 2003.  When I open a .xlsx file it opens with 2010.  I want ALL Excel files...old version and new...to open with 2010 all the time by default.  It's only occasionally where I will manually launch Excel 2003 and use the "open" command to locate an old file that I want to see in the 2003 version.  How can I get Excel 2010 back to opening ALL excel files by default (.xls and .xlsx)?  Window 7 seems to have lost the file associations feature that Windows XP used to have.
LVL 1
jbobstAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Davis McCarnConnect With a Mentor OwnerCommented:
Go to HKEY_CLASSES_ROOT\Applications\EXCEL.EXE in the registry and change the entries under shell which have "C:\Program Files\Microsoft Office\Office10\EXCEL.EXE" as a value to "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE".  Don't forget to leave the trailing /e in the new entry and, if you are on a 64 bit O/S, you may need "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE".  
0
 
Jason SchlueterIT ManagerCommented:
In the control panel there is an item called "Default Programs".  Give that a shot.
0
 
jbobstAuthor Commented:
I've tried that...it just says "Microsoft Excel".  Even though I browse to the .exe of Excel 2010 it still opens .xls files in 2003 version.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Jason SchlueterConnect With a Mentor IT ManagerCommented:
That seems really strange.  If you right-click the .xls file and choose "Open with...", you can specify the proper Excel executable and set it as the default.  After doing this, does it still open in the wrong version of Excel?
0
 
jbobstAuthor Commented:
There is only one Excel executable.  Not two...as you would hope to find (the two being Excel 2003 and 2010).  I can't simply tell Windows use Excel 2010 exclusively for ALL xls and xlsx files.  It just "knows" to use 2003 for xls files unfortunately.
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
I never try to run two versions of Office in one machine. Here, where you are using Windows 7, get XP Mode (free download from Microsoft) and run Excel 2003 (or even Office 2003) in XP mode. Uninstall Excel 2003 from Windows 7 and then you will have the best of both worlds.

.... Thinkpads_User
0
 
dew_associatesCommented:
You can run multiple versions of Excel within the Windows environment. This began with XP and continues through Windows 7. All you need to do is install them in ascending order - in this case install Excel 2003 and then Office 2010. Since you reversed this process, you need to run a repair.

Open the control panel "Programs and Features". Find the Office 2010 entry, select it, and click "Change". Follow the prompts to repair the installation and restore the file associations.
0
 
dew_associatesCommented:
I misread your post - sorry. Are you capable of editing your file associations in the registry?
0
 
dew_associatesConnect With a Mentor Commented:
If you're not, then you may want to have a look at this:

http://defaultprogramseditor.com/
0
 
Zack BarresseConnect With a Mentor CEOCommented:
It does sound like a file association issue.  Have you tried a repair?  You should run this on 2010.

Usually the last installed version will be what's used when you double-click on a file, unless you already have a previous version open, in which case it will try to hook the open version and use that (when you double-click).

If a repair doesn't work I would think about uninstalling/reinstalling 2010.  Or deleting all file associations and re-establishing them from scratch, but this is taken care of in an install, and should be done in a repair as well.

Regards,
Zack Barresse
0
 
aikimarkConnect With a Mentor Commented:
1. open a directory with a 2003 workbook in it.  
2. right click on the .xls file and choose Properties sub-menu item
3. Click on the default program button.  This might not be on the original tab on the dialog window.
4. select Excel 2010 icon
5. close the windows
6. double click the .xls icon to verify that it works.
0
 
jbobstAuthor Commented:
aikimark, tried that, there is only one Excel icon...that is my problem...that Windows doesn't distinguish between Excel 2003 and 2010.  I can't choose the default "open with" when it comes to xls and xlsx files.

firefytr, I did run repair and reinstalled didn't make a difference.

drew_associates, I can modify my registry, what registry entries should I edit?  I suppose a third party tool might work, but I haven't tried the one you suggested.  I was hoping for a more standard method.  After all, Microsoft did build all three software products (Windows and both Excel versions).  As mentioned, I did run repair...and that made 2010 be the default for both file types.  I can open Excel 2010 and use the file/open command and browse to a 2003 file version and it opens in 2010...but not by default.

Maybe the way it is, is the way it's designed and there just isn't a work around.  The main problem seems to be that file associations just aren't the same in Windows 7 any longer.  The fact that using the "open with" option ONLY gives ONE instance of Excel seems frustrating.  Windows SHOULD be able to tell that there are two version of excel, and two different file extensions, and allow me to decide how I want each file type to be opened.

At this point, we can live with this, so I am going to assign points and close the question.  Thanks for all the help.
0
 
jbobstAuthor Commented:
I some how missed DavisMcCarn's solutions.  I will try those registry changes.  Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.