Solved

MacBook Pro 10.8.4 Wi-fi Issues (won't connect to any secure networks)

Posted on 2013-06-26
51
290 Views
Last Modified: 2013-08-14
Hi all,

I have a rather strange issue I am hoping somebody can help me with. I am a tech guy so please feel free to get technical on me( I just am not an expert on Macs).

I have a MacBook Pro, purchased in early 2011 according to a serial number warranty check. Warranty has expired and I have no Applecare.


The machine was shut down last night as it normally would be(machine belongs to a family member). The next day, it was booted up and would simply not connect to any wi-fi networks, let alone even find them. The wi-fi adapter itself seemed to be stuck "off". Clicking Turn On did nothing.

I went ahead and did a PRAM reset. No luck
I then "inactivated" the wi-fi connection, removed it, re-added it, restarted. Half Luck.

Now my wi-fi turns on and will actually see networks, but here is the kicker:

It only connects to Non-secure networks (there is a non secure Linksys network in my area and I am able to connect and go online with it).

I have my home wireless (linksys router) on WPA2, and when I try to connect, it says "mac wifi could not join [wifi name].  a connection timeout occurred". Yes I am putting in the right key, I even changed the key to test, no luck.

I tried the same thing at my office, no luck, still says same issue, Cisco E1000 WPA2.

I have removed all the networks from the Preferred list, still no luck.
There is no filtering on any of the wireless routers, other laptops/phones/tablets connect fine.

Any advice? How come my Mac will only connect to non-secure networks?

TIA.
0
Comment
Question by:Spej
  • 22
  • 20
  • 7
  • +1
51 Comments
 
LVL 53

Expert Comment

by:strung
ID: 39279485
Try this:


1. Open system Preferences->Network pane, highlight the Wi-fi airport card and in the right hand pane turn OFF the airport signal. Then quit System Preferences.

2. Navigate to the folder /YourHardDrive/Library/SystemConfiguration/ and find the file: com.apple.airport.preferences.plist and drag to the Trash can (but don't Empty the Trashcan just yet.

3. Immediately Reboot to rebuild that file in the /SystemConfiguration/Preferences/ file.

4. Upon the reboot go back into System Preferences->Network pane and add you wireless card back and rejoin your network. In the right hand pane mark sure you push the 'Apply' button tom save.
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39279510
When I made the switch to mac, I was used to getting into gritty details on the pc.  That thinking does not always work well on the mac.

Option 1) System Preferences > Network > select on WiFI, on lower left, try removing, then adding back.


Option 2) System Preferences > Network > select on WiFI click "Assist Me" button and it will probably find the answer
0
 
LVL 1

Author Comment

by:Spej
ID: 39279515
strung,

In my Library Folder, I do not see a "system configuration folder." Also a search for "com.apple.airport.preferences.plist" returned back no results.
0
 
LVL 1

Author Comment

by:Spej
ID: 39279534
padas,

The "assist me" button only shows up when I connect to that unsecured "linksys" network.

When i ran Assist Me, It did not help. It said either network password wrong, network name wrong, or base is out of range.

No luck here.
0
 
LVL 53

Expert Comment

by:strung
ID: 39279563
Do the secured networks show up in "join other network" (you may have to wait a minute or two) or are you entering the SSID manually?

Also, (dumb question) did you check to make sure CapsLock is off?
0
 
LVL 53

Expert Comment

by:strung
ID: 39279573
Also, try opening KeyChainAccess and delete the entries for wireless networks.
0
 
LVL 1

Author Comment

by:Spej
ID: 39279575
strung,

The networks show up fine in my list, secured and non secured.

I tried entering the SSID and WPA2 key manually, same problem, "connection failed"

Caps locks is indeed disabled.
0
 
LVL 53

Expert Comment

by:strung
ID: 39279597
Try deleting the items in the keychain.

Also when entering the password, click on "show password" to make sure you are entering it correctly and that your keyboard mapping hasn't changed.
0
 
LVL 1

Author Comment

by:Spej
ID: 39279603
I am certain this is not an issue with the password, as I have gone into my router and changed the keys to match.

Also, even when I just enter random characters in the password field, it immediately throws same error.
0
 
LVL 53

Expert Comment

by:strung
ID: 39279631
Just for the heck of it, try temporarily using a really short WPA2 passphrase:

1234

and see what happens.

Also, have you deleted the Keychain entries?

You could also try making a new location in the Network prefs.
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39279640
Are you on the latest version of the current os?  Click the apple icon and Software Update.

Sometimes that seems to magically fix things.
0
 
LVL 1

Author Comment

by:Spej
ID: 39279690
strung,

WPA2 minimum is 8 characters, I tried 12345678 and still no luck.

I deleted Keychain entries, no luck.

I made a new network location, no luck.


padas,

I am on the latest version OS.
0
 
LVL 53

Expert Comment

by:strung
ID: 39279705
See if there is anything in the console logs that might give more details as to the error.

You could also check the logs on your router.
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39279729
What happens if you create a non secure connection on your network?  Are you sure it is a secure vs non secure thing and not dumb luck that it happend to connect to the network that is not yours?

Did the mac's local IP get reset when restarted and the router only accepts specific local IP?

Is the router broadcasting the ssid?
0
 
LVL 53

Expert Comment

by:strung
ID: 39279774
Pull down the Wireless menu while holding down the option key and choose Wireless Diagnostics.
0
 
LVL 1

Author Comment

by:Spej
ID: 39279868
strung,

Nothing that helps in the logs on the router.

In the mac console logs, all I see are "wlEvent: en1 en1 link DOWN" when I try to connect to my secured office wireless network.

padas,

I removed the WPA2 security on my office wireless and the Mac connected to it fine and went online. So it definitely has something to do with connecting to Wireless networks that are secured with WEP/WPA2.

I also did a software update, took about a half hour but it finished, no luck still.

This is rather bizarre and frustrating.
0
 
LVL 1

Author Comment

by:Spej
ID: 39279871
Interesting link I found, software updates cause Airport problems. Hope my Macbook wasn't a victim(however that link is 5 years old)?

http://discussions.apple.com/thread.jspa?threadID=883021&start=0&tstart=0
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39279904
Try the software update again....just incase there is another
0
 
LVL 1

Author Comment

by:Spej
ID: 39279911
Checked again, no updates available, all new are installed.

I am searching the Internet, and people are saying 2011 Macbook Pro's have bad wlan hardware. This is quite frustrating.

Is there a USB wi-fi card that can work with this laptop?
0
 
LVL 1

Author Comment

by:Spej
ID: 39279923
Another link I found:
https://discussions.apple.com/thread/2767037?start=0&tstart=0

Says WPA2 passwords with special characters will not work.

Our wireless password is:
123456890!

I tried with WPA2, no luck.
Tried with WPA2 and pw 1234567890, no luck.
Tried with WPA and pw 1234567890, no luck.
Tried with WPA with pw 1234567890!, no luck.
Tried WEP with 1234567890, no luck.

Tried with NO SECURITY on this wi-fi network, connected right away.


Seems like Apple bug to me, even though I have tried with a Netgear, Cisco/Linksys, D-Link router and even tried thethering to a Samsung Galaxy Note 2 and iPhone 5, all same problem.

Help!
0
 
LVL 53

Expert Comment

by:strung
ID: 39280040
You shoulldn't be having these problems. Have alook at the console logs and router logs as I suggested to see if you can get  a more detailed error message as to where the connection is breaking down. Also run the wifi diagnostic report as I suggested.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280053
Have you tried rebooting your router?
0
 
LVL 1

Author Comment

by:Spej
ID: 39280075
strung,

Of course I shouldn't be having these problems, it seems like no one can answer my question so far, perhaps its a bug. I have checked router and console logs, however whenever a "connection fails" on the Mac it does not spit out a specific error message that gives me an error code or anything. So I have no reference point or place to start.

I have rebooted my router at home, office, and at neighbors with no luck. Many, many times.

Again, it connects to non secure networks but fails as soon as it tries WPA/WPA2.

Help.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280079
Any luck with the Wifi Diagnostic Report?
0
 
LVL 53

Expert Comment

by:strung
ID: 39280083
Incidentally, my computer is also an early 2011 MacBook Pro running 10.8.4 and I have no problems connecting to WPA2, so it would not seem to be a generic problem.

Try creating an new Admin user in the Users and Groups prefs panel, then log in as the new user and see if the problem persists.
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 1

Author Comment

by:Spej
ID: 39280090
strung,

I have the Wi-fi diagnostic report on my desktop, what do you need from it?
0
 
LVL 1

Author Comment

by:Spej
ID: 39280098
strung,

I just tried a new Admin user and tried connecting, same exact issue unfortunately.
0
 
LVL 1

Author Comment

by:Spej
ID: 39280103
I should add that wired ethernet connection works fine no problems.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280135
Let's have a look at the following:

wireless diagnostics log
wifi.log
0
 
LVL 53

Expert Comment

by:strung
ID: 39280143
My earlier post about deleting the airport prefs plist was in error about the location. Try the following instead:

1. Open system Preferences->Network pane, highlight the Wi-fi airport card and in the right hand pane turn OFF the airport signal. Then quit System Preferences.

2. Navigate to the folder /YourHardDrive/Library/Preferences/SystemConfiguration/ and find the file: com.apple.airport.preferences.plist and drag to the Trash can (but don't Empty the Trashcan just yet.

3. Immediately Reboot to rebuild that file in the /SystemConfiguration/Preferences/ file.

4. Upon the reboot go back into System Preferences->Network pane and add you wireless card back and rejoin your network. In the right hand pane mark sure you push the 'Apply' button tom save.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280147
At the same time delete the following files from the same folder:

preferences.plist
com.apple.network.identification.plist
NetworkInterfaces.plist
0
 
LVL 1

Author Comment

by:Spej
ID: 39280155
strung,

Tried your steps above, twice, no luck, same issue persists.

Also I will post up those diagnostic files.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280158
This is very puzzling.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280161
Try booting from the recovery partition by booting while holding down Command-R. See if you can connect to your wireless network while booted from the recovery partition.

Since you will be using entirely separate software, this should tell you whether your problem is hardware or software. If you can connect from the recovery partition, your problem is software. If not, it is hardware.
0
 
LVL 1

Author Comment

by:Spej
ID: 39280164
strung,

Surprisingly, when booted from recovery partition, the machine connects to the secured WPA2 network just fine. Definitely a software issue.

o_O

thoughts?
0
 
LVL 53

Expert Comment

by:strung
ID: 39280172
That is good news. At least we know it is not a hardware problem.

Bedtime for me, though.

Here are a few Hail Marys to try:

1. Download Onyx http://www.titanium.free.fr/downloadonyx.php and use it to clear all your caches.
2. Clear your PRAM by cold booting while holding down the command-option-p-r key combination until you hear the startup chime a third time.
3. Use Disk Utility to Repair Permissions.

http://osxdaily.com/2012/11/30/resolving-stubborn-wi-fi-connection-problems-in-mac-os-x/
0
 
LVL 1

Author Comment

by:Spej
ID: 39280191
strung,

Tried those in your list, still no luck, I appreciate the help, I will keep hunting.
0
 
LVL 53

Expert Comment

by:strung
ID: 39280863
Is there any possibility that you have non-standard keyboard mapping and the computer is not  typing what you think it is typing into the password box? Do you have the keyboard set to the standard US keyboard?
0
 
LVL 53

Expert Comment

by:strung
ID: 39280871
Do you have the Mac firewall turned off? No anti-virus or security software?
0
 
LVL 53

Expert Comment

by:strung
ID: 39280888
Try downloading and running the 10.8.4 combo updater:

http://support.apple.com/kb/DL1659
0
 
LVL 53

Expert Comment

by:strung
ID: 39280997
In your network settings make sure you don't have any boxes ticked under the Proxies tab.
0
 
LVL 1

Author Comment

by:Spej
ID: 39281621
strung,

The keyboard is indeed US based.

We tried with Mac firewall on and off, no luck.
We tried with Sophos AV and did a scan, no luck.
Removed Sophos, rebooted, no luck.

There are no boxes ticked under Proxies.

I will try the Combo updater this afternoon. At this point, it seems like Mac OSX reinstall is the easier solution.
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39281659
There is a good chance they user has apple care, before you do a reinstall, that may be a good last resort.  Even if they don't have apple care, nicely and briefly explain the issue and yo have already tried everything.  Sometimes, they will still give you a little help.
0
 
LVL 41

Expert Comment

by:Jackie Man
ID: 39286813
0
 
LVL 1

Author Comment

by:Spej
ID: 39290626
jackeiman,

I will check this and reply back shortly.

thanks.
0
 
LVL 1

Accepted Solution

by:
Spej earned 0 total points
ID: 39308375
The Airport inside the laptop was the culprit. Ended up purchasing a replacement for $27, and watched a Youtube video on the replacement. Took about 4 hours of work, saved myself a boatload of cash. Thanks for the help all.
0
 
LVL 41

Expert Comment

by:Jackie Man
ID: 39309039
Glad to know you have solved the problem. Cheers!
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39309094
Did the airport allow you to get internet at all?
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39397084
What was the fix?
0
 
LVL 53

Expert Comment

by:strung
ID: 39397118
Read the author's last comment about three messages above yours.
0
 
LVL 1

Author Closing Comment

by:Spej
ID: 39407375
I figured this out on my own.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

EE introduced a new rating method known as Level, which displays in your avatar as LVL. The new Level is a numeric ranking that is based on your Points. This article discusses the rationale behind the new method and provides the mathematical formula…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
The Bounty Board allows you to request an article or video on any technical topic, or fulfill a bounty request to earn points. Watch this video to learn how to use the Bounty Board to get the content you want, earn points, and browse submitted bount…
Where to go on the main page to find the job listings. How to apply to a job that you are interested in from the list that is featured on our Careers page.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now