VMware Player 5 Bridged Connection not Working with Windows 8 Host and WiFi

Hello guys,

I am running VMware Player 5 on a Windows 8 host. I have a LAN adapter which is not in use and an Intel Centrino Ultimate-N 6300 AGN which is in use.

I can connect my VM using NAT but bridged connection does not work. When I try to configure it or use vmnetcfg.exe to see the network adapters, I don't see the Intel Centrino Ultimate-N 6300. Instead I see two of the type Microsoft Wi-Fi Detect Virtual Adapter.

Is there a way to make this work? I need bridged connection, so staying with NAT is not an option for me.
Untitled.png
LVL 20
TheAvengerAsked:
Who is Participating?
 
honestman31Commented:
it is clear that problem is with the wifi card on your laptop
 just enable wifi ( don't remove the cable )  ,, connect the vm thru wifi connection ( wifi nic   last choice  in the drop-down menu or the one before )  .. and let me know the result
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
At least disable those bluetooth and other fake NICs. Then try.
0
 
TheAvengerAuthor Commented:
Tried it, no change. I tried to leave only the microsoft virtual ones (also one by one), still no luck.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
honestman31Commented:
well try this and let me know if it works
shout down the VM
go to the folder that has your VM files
look for the something.vmx  file   (  the vmx file )
back up that file ( copy it to somewhere else )
open the original file  ( in the VM folder )  with note pad ( or any text editor )
look for this line ( or similar to it )   ethernet0.connectionType = "nat"
delete that line
power on the VM  ..
it should be bridged now ..


if got problems then restore the file u packed up

Please let me know if that helps
0
 
TheAvengerAuthor Commented:
My line says:

ethernet0.connectionType = "bridged"
0
 
honestman31Commented:
seems to be ok ..
Well try the following
don't use automatic ..
you have 3  virtual adapters , try them one by one
I'd like t know how ur computer is connected to the internet ( or the network )  ..do you have a router/modem  that has DHCP  ?
0
 
TheAvengerAuthor Commented:
I have a TP-Link router with OpenWRT using DHCP. I have two machines: one desktop running Windows 7 with LAN connection to the router and one laptop with Windows 8 and WiFi connection to the router.

The same virtual machine works without any problems on the desktop. It shows the LAN card, the wifi card (the desktop also has a wifi) and also one microsoft virtual wifi in the bridged configuration. It works without a problem with bridged connection.

On the laptop the wifi adapter is not shown in the bridged configuration (as you saw). I found some posts that Windows 8 might be the problem but they were not conclusive. I don't know if it is a problem of the wifi adapter not being supported, Windows 8 not being supported as host or some configuration. I installed the newest version of vmplayer yesterday, so this should be fine.
0
 
honestman31Commented:
can u plz , shut down the vm ,  connect this lap top to through lan  cable ( disable the wifi connection ) .. power own  the vm .. and let me know if it works
0
 
TheAvengerAuthor Commented:
Yes, it works without a problem.

By the way, with only wifi connected on the laptop, the guest OS says "cable unplugged"
0
 
TheAvengerAuthor Commented:
As I said some posts were talking about Windows 8 and wifi. So it might be a combination.

I don't have my wifi adapter (nic) listed, so I cannot select it.

If I don't remove the cable connection works through it.
0
 
honestman31Commented:
i meant u select the wifi nic  in the drop-down menu ..( even if it is not yours ) .. and try try the 2 wifi u have in the list ..
0
 
honestman31Commented:
if doesn't work then i think you will need to buy a WIFI dongle ( cheap ,, about 6-8 USD ) then use it specifically for the VM
0
 
honestman31Commented:
one more thing i suggest u do is to install the wifi nic card driver on the VM itself ( if u have not done that already
0
 
TheAvengerAuthor Commented:
Having in mind that even vmnetcfg.exe does not see the wifi nic card, I don't think it is a problem of the VM. However this adapter is not very new (laptop is about 2.5 years old) so it is strange that is it not supported by vmware.
0
 
TheAvengerAuthor Commented:
Unless again it is a Windows 8 issue. Not very easy to verify that though (must install clean Windows 8 and test and then clean Windows 7 and test which is a lot of trouble w/o messing up my current installation)
0
 
honestman31Commented:
You should be able to see the wifi nic card in the device manager of the VM as well ..
however for the time being just stick with wired network when u want to run the VM until windows 8 got a fix or contact VMwere / or post in their forum .
0
 
TheAvengerAuthor Commented:
If the player does not see the nic, it will not give it to the VM either :-(

Unfortunately I work at clients and they don't provide wired networks, so this is not a plausible option.

I will try to get another wifi adapter (usb) and try it with it to exclude Windows 8 from the problem.
0
 
TheAvengerAuthor Commented:
I still don't know if it is the network card or Windows 8 but it seems to be one of these. Thank you for the support.
0
 
TheAvengerAuthor Commented:
For anyone landing here in the future: I asked the same question in the vmware forum (http://communities.vmware.com/message/2267612#2267612). RDPetruska suggested to check the settings of the adapter and if it had the VMware Bridge Protocol installed. I went to check the settings and I could not open them because the network connection said it was "bridged". However there was no option to remove it from a bridge and there was no bridge shown. So I uninstalled VMware Player (no change), removed the wifi adapter from device manager, reinstalled it and reinstalled VMware Player. Now it works like a charm
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.