DHCP Server on CentOS 6.4

I am setting up an Asterisk server. It is a Dell T110II with 2 NICs. I am running CentOS 6.4. My goal is to have two seperate networks. One for the Internet-accessible LAN (eth0), and one for the private non-internet-accessible LAN for the VOIP phones.

eth0 - needs Internet access. Plugged into the existing data switch with other PCs, printers, etc.
     IP               10.79.10.1
     Subnet        255.255.0.0
     Gateway     10.79.0.1
     DNS            10.10.0.99

eth1 - no Internet access needed. Plugged into a stand-alone, seperate switch
     IP                192.168.0.1
     Subnet         255.255.255.0
     Gateway      none
     DNS             none

I have installed dhcp on the server in order for the SIP phones to pick up and address during boot. Here is the dhcpd.conf file...

     #
     # DHCP Server Configuration file.
     #   see /usr/share/doc/dhcp*/dhcpd.conf.sample
     #   see 'man 5 dhcpd.conf'
     #
     default-lease-time 259200;
     max-lease-time 518400;
     ddns-update-style none;
     authoritative;
     subnet 192.168.0.0 netmask 255.255.255.0 {
     range dynamic-bootp 192.168.1.10 192.168.1.99;
     option broadcast-address 192.168.0.255;

Here is my /etc/sysconfig/dhcpd file

     # Command line options here
     DHCPDARGS=eth1

My questions is...what am I missing? The phones are not picking up an IP address from DHCP.

Thanks
education-dynamicsAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Daniel McAllisterConnect With a Mentor President, IT4SOHO, LLCCommented:
My first guess is that there is something else ALSO acting as a DHCP server on the physical network your phones are tied into. This really isn't necessary... in fact, putting the phones on a separate network isn't necessary (and will just make it harder to debug when you have problems) -- ESPECIALLY since you're on a 16-bit netmask LAN!

First, consider using only 1 DHCP server on your LAN -- your Linux system! ISC DHCP is the most flexible to use of any I've found.

Next, consider using a CLASS declaration for your phones... In my case, I use ALLWORX phones, so they all have MAC addresses that start with 000ADD... thus. I use the following:

NOTE: My system allows the handsets to get to the Internet through the Allworx system -- since this is an Asterisk system, you don't need this.

ALSO NOTE: The hardware subscring starts with a 01... you need this! Trust me!

class "Phones" {
        match if (substring(hardware, 0, 4) = 01:00:0A:DD );
}

pool {
        range   dynamic-bootp 192.168.0.10 192.168.0.99;
        allow   members of              "Phones";
        option  routers                 192.168.0.1;
        option  ntp-servers           192.168.0.1;
        option  boot-server             "192.168.0.1";
        option  domain-name-servers     192.168.0.1;
}

Upon further review of your posted config, your range was wrong... it needs to be 192.168.0, not 192.168.1 ... It can't work the way you have that done because the DHCP_ACK will fail:

- BROADCAST DHCP REQUEST
- RECEIVE DHCP OFFER 192.160.1.10
- REPLY WITH DHCP ACK from 192.168.1.10 to 192.168.0.1 -- wrong network, no connection

Either way, I hope this helps...

Dan
IT4SOHO

Even so, you need
0
 
education-dynamicsAuthor Commented:
I could not get DHCP to work, so I just assigned static IP addresses since there were only 14 phones.
0
All Courses

From novice to tech pro — start learning today.