Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Keep getting index errors on Exchange 2010 server

Posted on 2013-06-27
10
Medium Priority
?
2,692 Views
Last Modified: 2016-08-04
I'm seeing repeated errors in the event log on my 2010 exchange server:

Content Indexing function 'CISearch::EcGetRowsetAndAccessor' received an unusual and unexpected error code from MSSearch.
Mailbox Database: 2010_DB3
Error Code: 0x80043629

This appears for each of the 4 databases I have every 10 minutes or so.  I've done the following which worked for a day but it showed back up again this morning:

Run Repair-ExchangeSearchSymlinks.ps1
Run .\ResetSearchIndex.ps1 -force 2010_DB3

Any ideas on what the root cause of this is and how I can prevent it?
0
Comment
Question by:First Last
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 12

Expert Comment

by:SreRaj
ID: 39283621
Hi,

As per Microsoft this error is logged because Exchange Search has a hard-coded prefix search limit of 200,000 nodes for a single character search. They are saying this is fixed in Update Rollup 6 for Exchange Server 2010 Service Pack 1. Do you have it already in your environment?

SP1 Rollup 6 - http://support.microsoft.com/kb/2608646

Details regarding this error can be found at http://support.microsoft.com/kb/2616127
0
 
LVL 1

Author Comment

by:First Last
ID: 39284187
I am fully patched as of today, I did that rollup back when it came out.  The odd thing is this wasn't always a problem, only in the last couple of weeks.  I can't figure out what has changed.
0
 
LVL 26

Expert Comment

by:Blue Street Tech
ID: 39285895
Hi danbrown1888.

Rerun the schema upgrades for SP1 (using the sp1 setup files...) and restart the exchange services. After that, search should work as intended again.

Also, check 'Microsoft Search (Exchange)' service on Client Access Servers is NOT set to 'Manual' and not running. Start and set to Automatic.

Did you execute your remediation per this article? http://blogs.technet.com/b/exchange/archive/2011/06/30/after-installing-exchange-2010-service-pack-1-searching-via-owa-or-outlook-online-mode-fails.aspx
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 12

Expert Comment

by:SreRaj
ID: 39289188
You could try manually rebuilding the Full-Text Index Catalog. To manually rebuild the full-text index catalog, stop the Microsoft Exchange Search Service, delete the old catalog, and then restart the service. This procedure forces the server to re-create the full-text index catalog.
Following are the procedure to manually re-create index catalog.

1.Stop the Microsoft Exchange Search Service by running the command: Net Stop MsExchangeSearch
2.Delete the full-text index catalog directory
The directory name of index catalog follows the convention CatalogData-<guid>-<guid> where the first <guid> is the GUID of the database, and the second <guid> represents the Instance GUID, which is used on a clustered mailbox server to distinguish between the nodes. Example for an index catalog is ‘CatalogData-b56624f3-bf19-4463-926f-d4705ac3dd08-cc64dd2d-2428-4f12-bba2-79d6d34c4d27’. Delete this folder.
3.Start the Microsoft Exchange Search Service by running the command: Net Start MsExchangeSearch

Following screenshot shows how you can locate the CatalogData folder.

CatalogData Folder
0
 
LVL 1

Author Comment

by:First Last
ID: 39289814
@diverseit - I can try that, do you know if it would cause any issues since I'm already on SP3?  This is a two member DAG so I assume it should be done on both sides.

@SreRaj - I've run Repair-ExchangeSearchSymlinks.ps1 and .\ResetSearchIndex.ps1 [-force] <dbname> [<dbname>] which seems to help for a short time but the error always comes back.  Will doing it the manual way you suggest be different than using the scripts?

Of the two options here is there a consensus on which approach might work best?  I'd lean towards manually deleting/rebuilding the index if its likely to work.
0
 
LVL 12

Expert Comment

by:SreRaj
ID: 39293225
Running ‘.\ResetSearchIndex.ps1 -force 2010_DB3’ is same as manually deleting and re-creating catalog folder. If there is a DAG copy for the database, then you should update the content index for the copy using the following command.

Update-MailboxDatabaseCopy -Identity <DBCopyName>\<DBCopyServerName> -SourceServer <SourceServerName> -CatalogOnly

Also, it is specified in the following thread that restarting ‘Microsoft Exchange Information Store’ too fixes this problem.

http://social.technet.microsoft.com/Forums/exchange/en-US/bded36b7-8fa1-42ab-9303-5b3f38d95a27/owa-search-issue
1
 
LVL 1

Author Comment

by:First Last
ID: 39293257
Hi SreRaj

I think you may have something with the updatemailboxcopy command, that's one thing I haven't tried yet.  It is a two member DAG so I'll try running that command after hours this week and see how we do, thanks!
0
 
LVL 1

Accepted Solution

by:
First Last earned 0 total points
ID: 39314004
This was resolved by reinstalling the filter pack, there must have been some kind of problem when it was updated during SP2.
0
 
LVL 1

Author Closing Comment

by:First Last
ID: 39325986
Found own solution
0
 
LVL 8

Expert Comment

by:Senior IT System Engineer
ID: 41743589
First,

Where did you download th Filter pack that is not comaptible with the Exchange Server 2010 SP3 ?
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
how to add IIS SMTP to handle application/Scanner relays into office 365.
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question