Solved

"Cannot allocate memory" while formatting a hard drive Mac OS X

Posted on 2013-06-27
7
2,756 Views
Last Modified: 2013-06-28
Hello, I just bought a WD My Passport 1 TB external hard drive to plug into my MacBook OS X (10.6.8).  When I try to format it I get the error POSIX reports: The operation couldn't be completed. Cannot allocate memory.  This happens if I try to erase it or partition it.  Currently there is no partition on the hard drive as it did erase.  I'm trying to format for Mac OS Extended (journaled) as I was instructed.

Anyone have any ideas what I can do to format this drive?

TIA

Jay
0
Comment
Question by:jayligda
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 53

Expert Comment

by:strung
ID: 39282623
0
 

Author Comment

by:jayligda
ID: 39282748
Thanks for the article:

"You can use terminal commands as alternatives to initially format the drive and hopefully allow it to be accessible via Disk Utility again."

This did not work for me.  From what I read it seems to be an issue with the OS.  I'll take it to the Genius Bar and see if they can help.
0
 

Author Comment

by:jayligda
ID: 39283253
I took it to the Genius Bar at the Apple store.  The intake tach instructed me to set up my computer to show me the issue so he'll know which genius could best help me.  I plugged everything in and started the format.  It formatted without an issue.  I thanked him and left.

I believe the issue was that I had the hard drive plugged in through a USB hub.  I mentioned that to the tech (I really didn't leave right away).  he said that definitely could have confused things.
0
Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

 
LVL 47

Accepted Solution

by:
noxcho earned 500 total points
ID: 39283905
Your problem was seemingly in the USB Hub not getting enough energy. So the drive was not fully functional. As soon as you connected it in a different hardware it worked for you.
This happens often with External USB enclosures or even external HDDs. So sometimes the drive have two USB connectors to get more power for successful work.
0
 
LVL 53

Expert Comment

by:strung
ID: 39284003
I agree. You need a powered USB hub.
0
 

Author Comment

by:jayligda
ID: 39284683
I was going to comment that it is a powered USB hub, but then realized it was not plugged in :-)

I plugged it in and tried reformatting.  It worked!
0
 
LVL 53

Expert Comment

by:strung
ID: 39284706
Ha Ha!
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Windows 2012 R2 - Backing Up Server 3 59
SSD mSata 250GB 37 97
evulating CPU from family/model/stepping #s 6 44
Purchase larger hard drive for Dell Latitude e7250 laptop 3 76
VM backups can be lost due to a number of reasons: accidental backup deletion, backup file corruption, disk failure, lost or stolen hardware, malicious attack, or due to some other undesired and unpredicted event. Thus, having more than one copy of …
This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question