Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

RDP to windows 7 doesnt work

Posted on 2013-06-27
25
Medium Priority
?
446 Views
Last Modified: 2013-07-02
Dear experts,

I have a very strange problem. I try to RDP from a windows 7 laptop to a windows 7 desktop. But whatever i do, it seems to fail.

- I opened port 3389 on the windows firewall.
- Unistalled every peace of anti-virus / firewall software i could find.
- Checked all services.
- Made sure that remote connection is allowed.
- even tried disabling the windows firewall.

Nothing worked. Can anyone help me?
0
Comment
Question by:mspren
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 9
  • 2
  • +2
25 Comments
 
LVL 10

Expert Comment

by:Sam Simon Nasser
ID: 39283528
right click computer - properties - remote
select the second option as in the image below
1also, press select users and add users allowed to connect (try with everyone and grant all access)
2
0
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 39283530
Are you trying to remote via the LAN or WAN?
0
 

Author Comment

by:mspren
ID: 39283533
Dear experts,

i try it on LAN. And the settings in the screenshot are correctly set.
0
Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39283542
Once I had the same problem, I stopped the RDP Service by saying "Dont Allow to this computer".

And restart the PC.

We then come back to enable remote access.
0
 

Author Comment

by:mspren
ID: 39283556
Where did you do that?
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283564
Did you forward ports on the router.

You can also follow the steps mentioned in this article

http://www.sysprobs.com/connect-remote-desktop-windows-7-fix



Ded9
0
 

Author Comment

by:mspren
ID: 39283568
Ded9 thanks i found this link already but it did not help me.
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283585
Run this command on both compute to find out whether the rdp port is listening


netstat -a | find "3389"


or netstat -aon | more



Post screenshot of both systems.



Ded9
0
 

Author Comment

by:mspren
ID: 39283595
ok i did that. 1 screenshot is pc i try to rdp to second screenshot is pc i try to rdp from.
1.png
2.png
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283601
In the above screenshot 1.png rdp is not listening you need to enable rdp here.

In 2.png the rdp is listening ..try rdp from 1 to 2.

Post results.



Ded9
0
 

Author Comment

by:mspren
ID: 39283602
where do i do that? is it a service or can i do it any other way?
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283604
Launch services.msc and make sure terminal services is started and set automatic on 1st pc

Also did you first try connecting from  from 1 to 2.


Ded9
0
 

Author Comment

by:mspren
ID: 39283615
i cant find the service. can you tell me the cmd command?
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283623
Post the version of windows 7 on pc 1. RDP feature is not supported in windows 7 home premium.

You can connect from pc1 to pc2 but not pc2 to pc1 based on the screenshot that you have uploaded.

Also make sure all RDP related services are started and running. You can use teamviewer for free for personal use.

http://www.teamviewer.com/en/download/windows.aspx



Ded9
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39283634
@mspren

Under System Properties -> Remote Tab

Basically turn off RDP Access, restart and turn it back on :)

HTH

Imtiaz
0
 

Author Comment

by:mspren
ID: 39283643
I started the termservice but i still is not working.
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283656
After starting termservice run the netstat -a | find "3389" ..post screenshot.

Post the version of windows 7 you are using.

Is it windows 7, home, premium, professional etc.

RDP feature is not supported in windows 7 home premium



Ded9
0
 

Author Comment

by:mspren
ID: 39283679
output is still the same and the version is windows 7 professional 32bit
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283687
Run this from cmd


reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSCo
nnections /t REG_DWORD /d 0 /f

Run this from cmd and post screenshot

reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTS
Connections

Restart pc and then run this

netstat -a | find "3389"



Ded9
0
 

Author Comment

by:mspren
ID: 39283696
I did not make a screenshot cause everything is in german. I hate it. adding the registry keys was succesfull but after reboor it still doesnt find the 3389 port.
0
 
LVL 30

Assisted Solution

by:ded9
ded9 earned 2000 total points
ID: 39283710
Make sure are Rdp services are running ..terminal services.
Make sure you have allowed rdp in windows firewall.

First ..run this command

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 0 /f

then run this

reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTS
Connections

it doesnt matter if its in german..post screenshot.

then run this ...no need to reboot the system

netstat -a | find "3389"

and this

netsh firewall show state

post screenshot.


Reboot is not required.



Ded9
0
 

Author Comment

by:mspren
ID: 39283723
here the requested screenshots
3.png
4.png
5.png
0
 

Accepted Solution

by:
mspren earned 0 total points
ID: 39283753
Solved it:D:D

https://jackkb.net/securing-remote-desktop-on-windows-8-and-windows-7/

part 4 was the solution. Somehow the port was 3390 instead of 3389. thanks for all the good help.
0
 
LVL 30

Expert Comment

by:ded9
ID: 39283759
Glad to know your issue is fixed :)



Ded9
0
 

Author Closing Comment

by:mspren
ID: 39292587
Ded9 was of great help!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question