Enable and change FILESTREAM settings...

I am following the instruction from:

http://msdn.microsoft.com/en-us/library/cc645923.aspx#enabling

I am working with SQL Server 2008R (the above is for SQL Server 2012) assuming the process is the same.

There are 13 steps in this link. At the very first step:
1, On the Start menu, point to All Programs, point to Microsoft SQL Server Code-Named 2012, point to Configuration Tools, and then click SQL Server Configuration Manager.

I am getting an error stating "Cannot connect to WMI provider..."

Q1: How can I find out whether the Filestream is already enabled or not?
Q2: How can I deal with this error (see the attached image)?

FYI: Per MCTS 70-433 Training Kit, I am trying to Enable FILESTREAM settings to install some sample databases from the companion CD provided with the book.

Thank you.
FileStreamError.png
LVL 34
Mike EghtebasDatabase and Application DeveloperAsked:
Who is Participating?
 
Mike EghtebasConnect With a Mentor Database and Application DeveloperAuthor Commented:
PatelAlpesh,

Thank you for answering question 1.


Right-click on SQLEXORESS to select properties then
Select Advanced and change Filestream Access Level

I have "Full access enabled"
0
 
Louis01Commented:
Try the instructions in this link perhaps:
http://evry1falls.blogspot.com/2012/07/wmi-error.html

p.s. Right above the heading in the MSDN article, you can select the SQL version...
0
 
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
In this case, the version difference is not an issue I believe.
0
 
Alpesh PatelConnect With a Mentor Assistant ConsultantCommented:
DB Server properties
0
 
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
good solution description.

enable/disable of file stream identical for both 2008 and 2012
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.