Solved

SMTP outgoing email not work on SharePoint 2010

Posted on 2013-06-28
20
2,591 Views
Last Modified: 2014-02-01
I installed sharePoint server 2010 on windows server 2008 R2. The SharePoint is running on a test server. I configured SMTP to point to google mail. I also went to the SharePoint administration site and configured SMTP outgoing emails. When I create a task it does not send the notification. Connecting to the server on a telnet client works and I can send emails. What could be the problem.?
0
Comment
Question by:Atouray
20 Comments
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39284097
Do you need to authenticate to send from Google mail?  I really don't see how Google could allow open relay from their server.

SharePoint can't authenticate with SMTP servers.  You can get around it by using a local IIS SMTP server and configuring Google as a smart host.
0
 

Author Comment

by:Atouray
ID: 39284306
I configured the local smtp as a smart host for google mails. The local smtp works when I connect using telnet. I was able to send emails from the telnet interface to gmail users.
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39284316
Is this correct?

You have the SMTP service running on a web server.  You have that service configured to connect to Google mail to send all outbound email.  In Central Admin, you have your web server set in the Outgoing Email setting (and not Google).
0
 

Author Comment

by:Atouray
ID: 39284328
Yes @achilles I have the SMTP services running locally on that server. Convert as a smart host send all outbound to google. And the Central Admin SMTP settings points to the localhost smtp services. The smtp services on II6 is set to anonymous authentication.

Thank you
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39284334
Ok.  

Tasks aren't a good way to test outbound email, since they can be a bit flaky.  The best way to test is to add a user to a SharePoint group and choose to "Notify the user".  The outbound email will be generated immediately and there are hardly ever any issues with this type of notification.
0
 

Author Comment

by:Atouray
ID: 39284361
Hi @achilles thanks for that I used  adding user to a group and got this message

The user or users have been added successfully, but there was an error in sending the e-mail message. The server may not be set up correctly to send e-mail. To verify that e-mail is configured correctly, contact your server administrator.

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 95a78f7f-6d21-46dd-94d4-32ba896a7764

Date and Time: 6/28/2013 6:42:09 AM
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39284384
That's typically because you have a bad SMTP server address configured in the Outgoing Email box.  Also, verify it's not a different address on the web app.

You can set individual web app outgoing emails in APp Managment - Manage Web APplications - General Settings - Outbound Email
0
 

Author Comment

by:Atouray
ID: 39284428
Everything seem to be ok. Went to the web application mangement and verify the settings. I have my smtp server pointed to my IP address of the machine (the server itself) my from to address is the same address used at the IIS 6 smtp configuration which is the same as the reply to address.

I forgot to made mention of this, when I was configuring the II6 smtp, it refused to work on port 25. I saw an article online saying changing the port from 2525 will solve it. I did that and the SMTP started running. Could this be the case?
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39284990
Can google use a non 25 port?
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:Atouray
ID: 39284995
Well on the telnet interface I can send send email to google using that port. So I think they do
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39285012
0
 

Expert Comment

by:wish_C
ID: 39286078
How did you create the task?
0
 

Author Comment

by:Atouray
ID: 39286994
@achillis sorry for the late reply. I followed a similar article when I was doing the configuration but insteas of MS smtp I used that of Google's.

@wish_C I used the normal task creation. Added a title, an assignee (the individual the alert is to be sent) details, start date.
0
 

Author Comment

by:Atouray
ID: 39296655
I have changed the port to 25 and I have noticed that my messages are dumped to the queue directory but never delivered. Any idea what is going on?
173.194.68.109, OutboundConnectionCommand, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 78, 0, 4, 0, 0, EHLO, -, name.mydoamin.com,
173.194.68.109, OutboundConnectionResponse, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 140, 0, 51, 0, 0, -, -, 250-mx.google.com at your service, [-----------------------],
173.194.68.109, OutboundConnectionCommand, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 140, 0, 8, 0, 0, STARTTLS, -, -,
173.194.68.109, OutboundConnectionResponse, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 219, 0, 28, 0, 0, -, -, 220 2.0.0 Ready to start TLS,
173.194.68.109, OutboundConnectionCommand, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 422, 0, 4, 0, 0, EHLO, -, phoenix.isecured.com,
173.194.68.109, OutboundConnectionResponse, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 484, 0, 51, 0, 0, -, -, 250-mx.google.com at your service, [-------------------],
173.194.68.109, OutboundConnectionCommand, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 484, 0, 4, 0, 0, AUTH, -, -,
173.194.68.109, OutboundConnectionResponse, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 547, 0, 16, 0, 0, -, -, 334 UGFzc3dvcmQ6,
173.194.68.109, OutboundConnectionResponse, 7/3/2013, 5:45:11, SMTPSVC1, PHOENIX, -, 797, 0, 79, 0, 0, -, -, 534-5.7.9 Please log in with your web browser and then try again. Learn more at,

Open in new window

0
 
LVL 18

Expert Comment

by:Richard Daneke
ID: 39298086
Read the HELP files on your gmail account.  Some applications are now challenged with a 2-step authentication process.  SMTP is now using 567 and not 25.  
You are intending an sending all email messages from the same account?  or are you trying to use SMTP un-authenticated?
0
 

Accepted Solution

by:
Atouray earned 0 total points
ID: 39811376
Folks the problem was solved long time ago. Sorry I couldn't reply mainly because my account was locked. I had to open a browser on that server and logged in with my gmail account. Thats all I did and it worked.

Thank you all for your suggestions.
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39811992
Close the ticket.
0
 

Author Closing Comment

by:Atouray
ID: 39826065
It was solved by signing in to my account on that server. A suggestion that was not given by any of the experts
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
shadow copies 7 17
FlexNet and ususweb.dll 3 13
Microsoft Lync 2013 4 44
People keep losing connection to file server 4 30
The new Microsoft OS looks great, is easier than ever to upgrade to, it is even free.  So what's the catch?  If you don't change the privacy settings, Microsoft will, in accordance with the (EULA) you clicked okay to without reading, collect all the…
A procedure for exporting installed hotfix details of remote computers using powershell
The viewer will learn how to use the =DISCRINV command to create a discrete random variable, use this command to model a set of probabilities and outcomes in a Monte Carlo simulation, and learn how to find the standard deviation of a set of probabil…
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now