Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Outlook Web Access

Posted on 2013-07-01
11
Medium Priority
?
609 Views
Last Modified: 2013-07-23
Hi All,

We have recently installed a Server within a clients off - SBS 2008 (2nd hand)

This is a fresh install and everything works fine apart from the owa externally, it works internally fine using either https://servername/owa or https://remote.domain.com/owa

We can't even access the remote site from externally.

When we type in the static ip address into a browser it shows the IIS7 page for the http (port 80 redirect is working fine)

You would think it's an issue with the open ports but I have all the ports open on the Draytek 2830n router - 80,443,987 - i have even tested these on here - http://www.yougetsignal.com/tools/open-ports/

IIS seems to be running fine too, all the virtual directories are under the SBS Web Applications site and running.

I have even turned the server firewall off to see if that was blocking, still no luck.

Another strange thing is that when we open outlook a certificate pops up with autodiscover.domain.com as well as a few others of m.domain.com / mobile.domain.com / sites.domain.com - we do however have a RAPID SSL cert installed for remote.domain.com

Any ideas?

R
0
Comment
Question by:ryank85
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
11 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39290948
Was the certificate installed through SBS? There are multiple web sites and things can get complicated if the wizards in SBS were not used.

Outlook clients will connect to autodiscover.example.com by default as part of their configuration process. You either need to change the SSL certificate for something that can include that as one of the additional domains, or you need to configure SRV records for autodiscover on your external DNS.

Simon.
0
 
LVL 59

Accepted Solution

by:
Cliff Galiher earned 2000 total points
ID: 39290967
Sounds like you have a wildcard DNS record causing some problems. Note that this Woolf be an external record and not anything to do with SBS.

Additionally, some routers, and I know Draytek to be one of them, have an option to allow remote connections via SSL. Of that option is enabled, it will supersede and control port 443, despite any port forwarding rules you have. That would also mean any open port testing website/software would back with a positive result because the router IS responding on 443...but that traffic is not reaching your server.
0
 

Author Comment

by:ryank85
ID: 39291234
Hi

I installed the SSL cert through SBS Console, I can't even access the OWA using the static ip address either

I have rebooted the router again and now when I test the 443 port is doesn't show this as open.

When you say an external DNS issue, so this could be something on their hosting side, i.e 123-reg?

I will check the router for the SSL option

thanks

R
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ryank85
ID: 39291271
cgaliher - absolutely spot on with the SSL solution, changed the SSL option in the router to 449 and OWA worked - this must be a new option in the latest firmware as i've not seen that before.

With regards to the certicate popups would you recommend moving away from 123-reg or would this be something different, I notice on some hosting platforms you have either an A Record or CNAME record of autodiscover.domain.com - i notice this domain doesnt under their DNS settings on 123-reg

thanks again
R
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 39291285
Whether you relocate or not is up to you. But cleaning up your external records would be a requirement either way.
0
 

Assisted Solution

by:ryank85
ryank85 earned 0 total points
ID: 39333021
All sorted, we installed rollup 9 for exchange and everything works ok now

R
0
 

Author Comment

by:ryank85
ID: 39334342
I've requested that this question be closed as follows:

Accepted answer: 0 points for ryank85's comment #a39333021

for the following reason:

resolved ourselves
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 39334343
Your first and primary question was about OWA not working externally. Granted you did resolve the certificate issue yourself (which is why lumping multiple questions in EE should be discouraged) but the FIRST question you asked was about OWA. You rightly acknowledged that the router was the cause as I pointed out. You did NOT resolve the issue without the assistance of EE.
0
 

Author Comment

by:ryank85
ID: 39337552
Apologies, cgaliher resolved the OWA issue. I resolve the issue about the certificate.

Thanks
0

Featured Post

Enroll in October's Free Course of the Month

Do you work with and analyze data? Enroll in October's Course of the Month for 7+ hours of SQL training, allowing you to quickly and efficiently store or retrieve data. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New style of hardware planning for Microsoft Exchange server.
The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question