Solved

Visual Studio 2012 - stop debugging when IE closed / close IE when debugging stopped

Posted on 2013-07-01
4
1,161 Views
Last Modified: 2013-08-04
I am running Windows 7 on two computers, one with VS2010 and the other with VS2012. On either computer, when I start a website in debug mode it will open an IE window.  On the VS2010 computer, if I stop debugging it will close the associated IE window and if I close the IE window, it will stop the debugger.  On the VS2012 computer, this does not work.  I want VS2012 to behave like VS2010 does.  I have found several comments that says to use 'Detach All' if I don't want one to impact the other, but I can't find any instructions on how to make this work.  I did find some that says that this is supposed to be the default, but they don't explain how to reset this.

Can someone please tell me how to fix this?

Thank you!
0
Comment
Question by:stevelaforge
  • 3
4 Comments
 
LVL 23

Expert Comment

by:Roopesh Reddy
ID: 39294236
0
 

Author Comment

by:stevelaforge
ID: 39357794
I'm sorry that it took so long to get back...personal issues kept me from work.  This did not resolve the issue.
0
 

Accepted Solution

by:
stevelaforge earned 0 total points
ID: 39366944
I found the solution to this issue.  It appears to have to do with the installation of a later version of IE (10 in my case) after the installation of VS (2012 in my case).  I am not sure that it is limited to these versions, so I am qualifying my answer here.  I am also running on Windows 7, in case that matters.

The problem was that if I clck on the down-arrow located next to 'Internet Explorer' in the browser to debug with, I saw two 'Internet Explorer' entries, one of which was marked as the default.  Apparently this caused some confusion.  Now there may be two solutions, but the one that worked for me was to start the debugger but I selected Google Chrome for the browser this time, then stopped the debugger, came back and started it the debugger with IE again.  This time there was only one instance and everything worked just fine.

What I think may be another solution is to select the 'Browse with...' option under the list of browsers.  In this window, you have a choice to remove browsers from the list of options.  It may be that you could choose one here.  However, it isn't really clear what they are pointing at, which is why I chose the first option.
0
 

Author Closing Comment

by:stevelaforge
ID: 39380384
This solution worked perfectly for me.
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Summary Displaying images in RichTextBox is a common requirement with limited solutions available. Pasting through clipboard or embedding into RTF content only support static images.  This article describes how to insert Windows control objects int…
Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question