Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

RedHat REHL 6 - -bash: fork: retry: Resource temporarily unavailable

Posted on 2013-07-01
4
Medium Priority
?
10,021 Views
Last Modified: 2013-07-04
Hi,

I keep getting this error message while runnins some basic commands:

-bash: fork: retry: Resource temporarily unavailable

I have tried to check the ulimit of the user and it seems ok..

ulimit -a
core file size          (blocks, -c) unlimited
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 238128
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 10240
cpu time               (seconds, -t) unlimited
max user processes              (-u) 1024
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited


> ps -ef | wc -l
176


Any idea on why this is happening?

Tks,
jaoo
0
Comment
Question by:joaotelles
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 

Author Comment

by:joaotelles
ID: 39291631
I have raised the max user processes to 2048 and the problem seem to be gone...

The question now is: How do I make this change permanent for my user?

I used ulimit -u 2048... but this will not be permanent...

Tks,
Joao
0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 2000 total points
ID: 39292439
Edit /etc/security/limits.conf and add or change the soft limit for user process:

user               soft     nproc            2048

"Soft" limit is the value set at login.

Since you were able to raise the limit by "ulimit -u" there's obviously no need to adjust the "hard" limit (the value up to which the limit can be raised by the user with "ulimit -u").
0
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39293576
'ulimit' is a shell command that changes only the shell windows you are in. To change the soft limit permanently, you need to update limits.conf as suggested by wmp and run ulimit -Sn.
0
 

Author Closing Comment

by:joaotelles
ID: 39300858
Tks.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question