Outlook 2007 not showing embedded images in e-mail body

Hi Guys,

I am having difficulty to display embedded images in Outlook 2007;

Under 'Trust Centre / Automatic Downloads' window I have deselected the option
"Don't download pictures automatically ..."

Went to Editor Options on Advanced then 'Display e-mail content'
I unchecked 'Show picture placeholders'
* However when de-selecting this option, if you go into the mail message, the embedded images are displayed, but not in the preview and when you exit Outlook and re-open, the setting reverted back to selected.

In registry deleted the value under HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Security

Re-installed Office

Still no success ...

Any help will be appreciated,
Regards Rupert
Rupert EghardtProgrammerAsked:
Who is Participating?
Iain MacMillanConnect With a Mentor IT ManagerCommented:
normally you would have the Don't download images automatically ticked so only trusted contacts/addresses show their images, such as you company ones and anyone on your trusted list (HTML format).

every other message would then have the whitebox/red X showing.  your workaround will work once, but if you have any policy settings, these will likely cause the reset when Outlook is restarted.  You can right click on any message and under the Junk Mail menu you can choose to trust the sender, or sender's domain.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.