Solved

Exchange 2007 out of disk space error

Posted on 2013-07-01
7
399 Views
Last Modified: 2013-08-07
Hi,

I have a 110GB global mail box sitting in the journal. This mailbox has all the organization emails. I am trying to delete emails from the month of may 2013. After inserting the following command i am getting "there is not enough space available" error. I am using a 32-bit machine for running power shell which is separate to the exchange server.

Get-Mailbox -Identity globalmail | Export-Mailbox -TargetMailbox testuser -StartDate "01/05/2013 " -EndDate "31/15/2009 " -DeleteContent

I am then prompted for supplying values for target folder, i have just put inbox.

Global Mailbox is on the C drive of the exchange server and it has 45GB free out of 599GB
0
Comment
Question by:Perth-IT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
7 Comments
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 39293384
Hello,

Does the "testuser" mailbox exist? Also, you need to reverse your start and end dates. The start date should be the earliest date.

JJ
0
 
LVL 18

Expert Comment

by:irweazelwallis
ID: 39294946
Try doing smaller chunks as the local powershell will be trying to build a list of emails to the delete them, there shouldn't be a server limitation for this.

try a few weeks, then months and increase until you have removed the period you want or figured out the limit of processing
0
 

Author Comment

by:Perth-IT
ID: 39295172
There was typo error, the dates are between 01/05/2013 to 31/05/2013.

Testuser exists, do i need to delegate access to testuser for global mailbox
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:Perth-IT
ID: 39295362
I have managed to delete the emails and the properties of global mailbox shows reduced size but the database size hasn't reduced

Global mailbox is located in a database residing in journal
0
 
LVL 18

Accepted Solution

by:
irweazelwallis earned 500 total points
ID: 39295786
your database size won't reduce down without further action as it writes out to the whiespace

if you look halfway down this technet article is shows the eseutil command

if you want to shrink it down there is an offline action to defrag is fully and compact

http://technet.microsoft.com/en-us/library/aa998863(v=exchg.80).aspx
0
 

Author Closing Comment

by:Perth-IT
ID: 39388347
I have managed to delete the content
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this step by step procedure, you will come to know the details of creating an Outlook meeting in 2007, 2010, 2013 & 2016.
This video discusses moving either the default database or any database to a new volume.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question