Global Address List not updating

Hi,

I have two Exchange servers one in the US one in the UK, both are in the same domain the GAL list is updating for US side but not the UK although they are both configured in the same.

Any Ideas what would be causing this.

Thanks
LVL 1
Dan130Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
AmitConnect With a Mentor IT ArchitectCommented:
This can be ignored...
http://blogs.msdn.com/b/dgoldman/archive/2009/12/01/please-read-events-9320-and-9359-on-new-installation-of-exchange-2010.aspx

Next you can try this: Run both commands from EMS.
Get-OfflineAddressBook | Update-OfflineAddressBook
Get-ClientAccessServer | Update-FileDistributionService
0
 
Hendrik WieseInformation Security ManagerCommented:
Hi,

Please have look at my article to manually update your GAL: Manually Update Global Address List (GAL) on Exchange 2010

You can also watch my YouTube video here.

Hope this helps.
0
 
suriyaehnopCommented:
Which server is hosting the Default Global Address List? It is UK or US?
Is UK server contacting US server to sync the Global Address List?

You may check by launching EMC | Organization |Offline Address Book | Distribution tab
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
AmitIT ArchitectCommented:
Run this command and check again
Get-ClientAccessServer | Update-FileDistributionService
0
 
Dan130Author Commented:
The US server is hosting the Default GAL, I did move it to the UK but it had no effect. is does look like the UK is contacting the US server to sync yes.

I ran the command Get-ClientAccessServer | Update-FileDistributionService  doesn't looking like it had any effect after closing and reopening outlook.
0
 
AmitIT ArchitectCommented:
Are you refereeing to OAB as GAL? Did you checked with OWA.
0
 
Dan130Author Commented:
The default GAL on OWA looks fine. for both UK and US, so yes it would appear I am
0
 
AmitIT ArchitectCommented:
So it is issue with Offline Address book then. In this case you enable the Expert level logging for OAB and check for error under Application logs, if you see any error, post it here.

Let me know, if you need steps how to enable logging for OAB.
0
 
Dan130Author Commented:
I would yes, I had a quick look and I need to run the following command?

set-eventloglevel -Identity "MSExchangeSA\OAL Generator" -Level EXPERT -verbose


is this correct.
0
 
AmitIT ArchitectCommented:
Yes...
0
 
Dan130Author Commented:
This is the message i'm getting for all mailboxes now

OALGen truncated or dropped properties for entry 'Mailbox' in address list '\All Users' because they exceeded the configured size limits for the version 4 offline address list.  The affected MAPI ids are:  8008.
- \Default Offline Address Book

event id 9359
MSExchangeSA
0
 
Dan130Author Commented:
it also states that

OABGen successfully read all 260 objects in address list '\Global Address List' using Active Directory DCname and wrote the objects to files on disk.
- \Default Offline Address Book


so it doesn't appear to error
0
 
AmitIT ArchitectCommented:
ya both can be ignored, do this, go and check OAB folder date and time. When it was updated last time.
0
 
Dan130Author Commented:
16.12 PM  30 minutes ago its updating for the US visibly but not locally for the UK, I ran both them commands but nothing has changed on the OAB locally.
0
 
AmitIT ArchitectCommented:
Download OAB for user manually and check again. Or reconfigure a user profile for one user and check.
0
 
Dan130Author Commented:
ok I created myself a new Temp profile and the OAB is up to date.
0
 
Dan130Author Commented:
looks like the issue is then around the current outlook profiles not being updated
0
 
AmitIT ArchitectCommented:
Ya, profile corruption can also cause this issue. You can recreate profile for effected users.
0
 
Dan130Author Commented:
its all UK staff do you know of another way around it.
0
 
AmitIT ArchitectCommented:
How many users?
0
 
Dan130Author Commented:
56 Users in total. I can see the issue is that my local profile cannot even manually download the OAB as its get an error.

even when I recreate the profile it just show an up to date version but I still cannot manually update the OAB

I ran the command below which shows the OAB as blank
Get-Mailbox YourUser@Domain.com |FL OfflineAddressBook
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.