troubleshooting Question

ColdFusion CFThread Failed to Set Header?

Avatar of pmascari
pmascariFlag for United States of America asked on
ColdFusion Language
8 Comments1 Solution494 ViewsLast Modified:
I'm getting a weird error from CFThread.  I have it wrapped around a function that runs perfectly when outside CFThread.  But, it takes about 20 seconds to complete so I shoot it off to CFThread then CFLocation the user to a new page and alert them when it's done.  

It's also wrapped in CFTRY to email me should there be a problem.

I'm getting emails where the CFCATCH.Message is:

"CFThread failed to set header to response as request had already completed"

I can't find any reference to an error like this on Google.  I'm assuming it's not liking the fact that I'm using CFLocation directly after invoking the Thread.  So, for the hell of it, I tried using a META REFRESH to redirect the user instead.  Same error result.

Any ideas?
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 8 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 8 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros