Service failed to start. Verify that you have sufficient privileges to start system services.

I have a fresh Windows Server 2008 R2 64-bit box.  It has nothing but Windows updates on it so far.  I'm trying to run an MSI file that will install a system service, but when I run the MSI I receive the following error:

"Service 'AI MyMeter v4 Data Services' failed to start.  Verify that you have sufficient privileges to start system services."

I've checked Windows Firewall, UAC, DEP, I've tried 'Run as Administrator', I added the 'Log on as a service' right to the account (local Administrator), and I'm not sure what could be preventing this from installing.
mymeter.gif
fallriverelectricAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pradeep DubeyConsultantCommented:
The built-in Administrator account in Windows Server 2008 R2 does not run in Admin Approval Mode so you have to install it from command prompt.

1) right click on CMD.EXE and select run as administrator
2) now provide full path of the MSI file
3) continue with the installation.
fallriverelectricAuthor Commented:
I still get the same error when I try it this way.
Pradeep DubeyConsultantCommented:
Or you can use command line installation

from an elevated command prompt run below command
msiexec /a d:\Setup.msi  (D:\setup.msi is the full path of your installation file)

you can use /i also if not installing... (/i for installation)
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

fallriverelectricAuthor Commented:
When I try msiexec /i d:\Setup.msi I receive the same error.  

When I do msiexec /a d:\Setup.msi instead it quickly opens the installation, the bar goes all the way across, and the window closes as if the program installed.  But it didn't install and isn't listed in services still.
MHMAdminsCommented:
Move the installer file to your desktop, then right click and run as administrator instead of running it directly from the c:\ directory.
fallriverelectricAuthor Commented:
When I move the installer file to the desktop there is still no 'run as administrator' option.  I tried a normal install from that location with the same results.
MHMAdminsCommented:
try ctrl+right click and then run as different user then select   .\administrator and the password for the local administrative account.
Pradeep DubeyConsultantCommented:
It is not CTRL+right click it is shift+right click for the different user option.
Pradeep DubeyConsultantCommented:
Also can you try to download this msi file again, if its not installing using command prompt then seems it has some issue.

Try to download it again or copy from the source again.

Dont forget to match the MD5 on both side..
fallriverelectricAuthor Commented:
Apparently the file needed .NET 4.0 to work properly.  After installing .NET 4.0, the installer runs fine.  Thanks everyone for your help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fallriverelectricAuthor Commented:
Apparently the file needed .NET 4.0 to work properly.  After installing .NET 4.0, the installer runs fine.  Thanks everyone for your help.
Pradeep DubeyConsultantCommented:
So you did not check the precondition before installing the application.
fallriverelectricAuthor Commented:
The application didn't list any preconditions, nor did the vendor who gave us the executable file.  This appeared to be news to them as well.
Jashandeep BalCommented:
Try installing application in offline mode. Turn wifi off or disconnect network cable and try.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.