troubleshooting Question

Cisco 2821 sample config for internet access with one static ip.

Avatar of byron-bolton
byron-boltonFlag for United States of America asked on
Network Management
3 Comments1 Solution1489 ViewsLast Modified:
I need some help in setting a cisco router up so that all devices can access the internet. If i log into the rouer I can ping yahoo.com and 4.2.2.1 from the router. But none of the devices can connect to the internet. They can ping each other, but not outside access.  I followed a few instruction I've seen with the config I have below, but no luck:

Router = Cisco 2821
Switch= Cisco 3550
Thanks
GB-B1-RT1#!


GB-B1-RT1#sh start
Using 3071 out of 245752 bytes
!
! Last configuration change at 13:14:33 UTC Wed Jul 17 2013
! NVRAM config last updated at 13:17:30 UTC Wed Jul 17 2013
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GB-B1-RT1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$n1.2$85wCzIvxlSfpOi1o9gRJr0
!
no aaa new-model
!
!
ip cef
!
!
ip domain name globalbusinesssolutions.org
ip name-server 4.2.2.3
!
!
!
username admin secret 5 $1$9Vto$qfwYDjdgsXc6M87aA3qN/1
!
!
ip ssh version 2
!
!
interface GigabitEthernet0/0
 ip address 192.168.10.252 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 98.112.166.15 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/1/0
 no ip address
 shutdown
!
interface Serial0/2/0
 no ip address
 shutdown
!
ip route 0.0.0.0 0.0.0.0 98.112.166.1
ip route 192.168.10.0 255.255.255.0 192.168.1.251
ip route 192.168.10.0 255.255.255.0 192.168.10.252
!
no ip http server
no ip http secure-server
ip nat pool PUBLIC_NAT_IPS 98.112.166.15 98.112.166.20 netmask 255.255.255.0
ip nat source list NAT_ADDRESSES interface GigabitEthernet0/0 overload
ip nat inside source list NAT_ADDRESSES pool OUBLIC_NAT_IPS overload
ip nat outside source static 98.112.166.15 255.255.255.0
!
ip access-list extended NAT-ADDRESSES
 permit ip 0.0.0.0 255.255.255.0 any
 permit ip 192.168.10.0 0.0.0.255 any
ip access-list extended NAT_ADDRESSES
 permit ip 192.168.10.0 0.0.0.255 any
!
!
control-plane
!
banner motd
 TEST

line con 0
 exec-timeout 180 0
 password cisco
 logging synchronous
line aux 0
 password cisco
line vty 0 4
 password cisco
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17179881
ntp server 173.230.144.109
!
end
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 3 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros