We help IT Professionals succeed at work.
Get Started

Sudo broken on Ubuntu linux

claghorn
claghorn asked
on
1,154 Views
Last Modified: 2013-08-09
I get this when I try to do something as sudo.
sudo: must be setuid root

following some advice I went into recovery mode, and from command line as root
I tried:

chmod 4111 /usr/bin/sudo

and I could not do this, it said its a read only file system.

How can I get sudo back?
Comment
Watch Question
CERTIFIED EXPERT
Commented:
This problem has been solved!
Unlock 1 Answer and 13 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant

An Experts Exchange subscription includes unlimited access to online courses.

Get Started
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE