Terminal Server users can't connect via ODBC

This is a follow-up to a question I asked a couple of weeks ago.  The situation has now got worse.

I have an Access 2010 application, with MySQL 5.5  back-end, running in a remote-desktop environment.  The server is driven by Windows Server 2008 R2.

The front-end started life as an MDB, and has been under development for the past 12 months.  Everything was working fine until a couple of weeks ago, but now, none of the users can connect to the back-end.  The just get 'ODBC connection failed'.

Obviously the question is, what have I changed?  Well, at about that time, I changed the front-end into an ACCDE, and then into an ACCDR (the original MDB had been converted to ACCDB some months ago).  My first thought was that I needed a 64-bit MySQL connector, which I duly downloaded, ran the exe file and tried to install via c:\windows\odbcad32.exe in admin mode.  Odbcad32 didn't list it in the available drivers so I could't create a new System DSN.

However, I found that, in the master front-end, I was able to delete and re-connect MySQL tables using the same driver I had been using for the past 12 months.  I then gave one of the users a copy of the ACCDB master front-end, logged in as him, tried to set up an ODBC link, and found that his version of Machine Data Source didn't have the driver I had used.  This is presumably why the users' links are failing.

So now it looks more like a permissions problem than a system architecture problem. Any suggestions would be very much appreciated.
LVL 5
BelloneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dipopoCommented:
I think thats a known bug with the 64bit connector:

- it installs fine (into syswow64)
- ODBC Administrator in Control Panel does not show driver - presumably because it is the 64bit ODBC Administrator and is only showing 64bit drivers
- 32bit ODBC Administrator (as found in syswow64) does show the driver

Thanks

Dipopo
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dipopoCommented:
I'd install both really just to be sure, both 64bit and 32bit.

Dipopo
0
BelloneAuthor Commented:
Looks like that was the problem.  It's going now.  Many thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.