Outlook 2010 asks for password

I am running Exchange 2013 on Server 2012.  Windows 7 clients with Outlook 2010 work fine.  Windows XP clients with Outlook 2010 prompt for credentials (user name and password) each time Outlook is started, and checking the "Remember my password" box does not prevent this from happening the next time.  The "Always prompt for logon credentials" checkbox on the "Security" tab of the "More Settings" section of the Exchange account is not checked.
Please help me to get this fixed.

Kind Regards,
Jacob Romkes
jromkesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Your best option is to dump the security risk called Windows XP.

Otherwise, do you have a trusted SSL certificate? What authentication settings have you configured in Outlook Anywhere? If currently negotiate, switch to NTLM and see if that helps.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
unknown_routineCommented:
This should be fixed by Microsoft. This was a bug for Office 2010.

This was fixed in SP1, do these XP users have upgraded to MS office SP1?


A workaround for this issue is to delete Outlook mail Profile in Control Panel,Mail, and recreate it.
0
jromkesAuthor Commented:
unfortunately dumping XP is not an option at the moment.

We use trusted SSL certificates and the internal and external sites are set to use the url of the domain in the certificate.

Just set all authentication to NTLM (and did IISreset), did not help

Office 2010 is at SP2

Recreating Outlook profile did not help

Dissconect and Connect workstation to domain does not help

New windows user profile does not help
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Simon Butler (Sembee)ConsultantCommented:
Authentication prompts don't always mean there is a problem with the user name and password. It can be any number of things.

Is the SSL certificate a wildcard certificate or a named certificate?

What results do you get if you run this command?

get-OutlookProvider exp

If the host name doesn't match the common name on your SSL certificate, that could cause a problem.

As painful as it may sound, anything later than Office 2007 and Exchange 2007 with Windows XP is not a good experience.

Simon.
0
hecgomrecCommented:
I will assume you have try all the profile recreations before you started this tread.

I will assume you have this error at a given time after you have created the outlook account on the users XP machines.

I had similar issues with my users even with Win7, in my case this was caused by authentication expiring on the accounts, users tend to login and never log off as a result the user becomes non-valid for exchange, having the user log off and log in have resolve this issue for me many times.

If this doesn't work for you, try this:

Change the account settings inside of Outlook to modify Outlook Anywhere. Go to and click "More Settings->Connections and un-check the box "Connect to Exchange using HTTP".

Good Luck!
0
jromkesAuthor Commented:
The SSL certificate is a named certificate.
get-outlookprovider expr gives the same name as in the certificate.
The accounts are not expired.

un-check "Connect to Exchange using HTTP" is automatic re-checked by starting outlook, why?
Also the connection URL in the same window is reset to the internal reference after restaring Outlook. Where to configure the URL exchange is advertising?
0
Simon Butler (Sembee)ConsultantCommented:
If you have Outlook Anywhere enabled, then Autodiscover will enable the option again. However that does NOT mean Outlook will use it.
If you right click on the Outlook icon while holding down CTRL then choose Connection Status, it will show you how Outlook is connecting. If it is using HTTPS then you have another problem, because that is failover behaviour only.

Does your trusted certificate include the internal names.
You probably need to reconfigure Exchange to use the external names internally. That includes the Autodiscover URL.
This is for Exchange 2010, but the configuration is the same on Exchange 2013.
http://semb.ee/hostnames

Simon.
0
jromkesAuthor Commented:
Simon,

Why is a https connection a problem? I found this in an article about Exchange 2013:
In Exchange 2013, Outlook Anywhere is enabled by default, because all Outlook connectivity takes place via Outlook Anywhere anyways.
Thats’ right. Its all HTTP now from exchange 2013

Both internal and external names are in the certificate.
0
Simon Butler (Sembee)ConsultantCommented:
My mistake.
That is my standard response for an Exchange 2010 user. Completely mixed up the versions involved in my last post.
The response above about deselecting use HTTP isn't going to work either, because you can only use HTTP for Outlook Anywhere.

It comes back to the original points though.
Is the SSL certificate trusted by the client and does the name you have configured for the internal address in Outlook Anywhere appear in the certificate?
If you browse to the address you have set Outlook Anywhere to use, do you get SSL prompts?

Are the Windows XP clients members of the domain?

Simon.
0
jromkesAuthor Commented:
We are starting to talk in arround, SSL certificate is not the problem, see 08-27
Problem is not fixed, client decided to replace the XP machines, so Sembee2 was giving the correct advice but not a cheap one.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.