• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 558
  • Last Modified:

Email account on Android

This can't be this difficult.  I set up phones for email all the time but I'm stumped with this one.  Note:  I did not set up this Exchange 2007 (SBS) server so it is possible there is some little setting somewhere I'm not aware of.  There is a GoDaddy certificate on this server that is working fine (as far as I can tell).  Ports 25,80, 110, 443, 587 and 465 are all open to the server, and the server is listening on all those ports.  Email has already been set up as POP mail for two IPhones and works fine (with SSL set) (not sure why they are set up as POP at this point, but the point is that it works...).  On these two androids, I just can't get it to work.  If I try to set it up as an Exchange account, and I tell it SSL and port 443, it tells me it can't connect to the server.  If I tell it no SSL and port 80, it tells me I have an incorrect user name and password (even though I know they are correct).  If I try to set it up as POP, if I tell it no SSL it will set up fine for incoming mail, but then for the SMTP server if I tell it no SSL and put in the authentication it fails with "Authentication not supported" and if I tell it SSL, Accept all certificates, it says "This server is not trusted since appropriate certificate is not installed on the phone."  It doesn't matter which port I try to use.  So I suspect there is something not right with the certificate, but I'm not sure what.  It appears to be correctly applied to Exchange, and SSL is working with the iPhones.  I'd appreciate any ideas!
1 Solution
Nick RhodeIT DirectorCommented:
I guess why are you not using active sync?  With the phone you have to make sure leave a copy on the server is checked in the properties.

POP3 setup:  http://www.rackspace.com/apps/support/portal/3918
I've seen this before with android. Try checking the box labeled something like 'accept any certificate' while setting up an exchange account, this should work fine!
landiiiks2Author Commented:
Thanks for your answers.  NRhode - I have tried to set it up as an Exchange account and had the problems stated above.  And I've tried setting up POP as your link suggests, and that doesn't work either.  And EvilKnievel, I did tell it "accept all certificates" in the Exchange settings but as I said above, it tells me it can't connect to the server with those settings.  If I do it as POP and say "accept all certificates" I get the "this server isn't trusted...." error.
Simon Butler (Sembee)ConsultantCommented:
The iPhone isn't as picky for SSL problems, therefore the fact that they work doesn't really mean much.

When you installed the GoDaddy certificate, did you install the intemediate certificate as well?
If you aren't sure, inside the GoDaddy system is a test site which will verify that your SSL certificate is installed correctly. I would start there.

You could also run a test account through the Microsoft test site at http://exrca.com/ however I doubt if that will tell you much.

Stick with ActiveSync though, POP3 is a battery drain.

landiiiks2Author Commented:
It turns out that the phone system people had installed an SSL certificate that "hijacked" SSL from Exchange.  Once that was straightened out, it worked fine.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now