Exchange 2007 Global Address Book and Offline Address Book Errors and Problems

We have been having a problem with it since the server was configured.  We are running SBS 2008 and Exchange 2007 SP3 all on the same box.  

When the server was put live in our company we had to configure Outlook to not use cached exchange mode because the Global Address Book wouldn't show anyone's email address except for 2 random ones.  When it's not in cached mode all the address do show correctly.  Also when we are using "online mode" then of course the spam filter in outlook isn't supported either.

Also we get daily in our server reports the following:

 Error Messages
Here is a screen shot when cached mode is turned off
Here is a screen shot when cached mode is turned on
cached mode
The first error message mentions about enough space but we have plenty on our server.  It also says to restore from a recent backup but all of our backups have these 3 events/errors since it happens daily.  I did read in the past about removing it from the server and recreating it but wasn't sure on the proper steps.  I figured I'd ask the experts.
Who is Participating?
jtrabertConnect With a Mentor Author Commented:
@CrisHanna - Nope not disabled but the server does have 2 nics in it.  I know only 1 is supported by SBS.  So I just disabled the second nic (which I thought already was)

@Sembee2 - Ok Ill give it a try, but just so I'm clear on what to do:

Remove the default address list
Create a new default offline address list
Only configure it for Public Folder Distribution
Right click choose update default offline address list
Now check the we distribution box
Update again
Thanks again for your help guys
Cris HannaCommented:
Let's start with some basics
How much RAM in the server?
How are your hard drives configured ?
How free Space on the C: drive?
Have you run the SBS best practice advisor?
Simon Butler (Sembee)ConsultantCommented:
Was this a fresh installation of SBS or a migration from a previous version?

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

jtrabertAuthor Commented:
Its an HP ProLiant DL360G6
16Gb RAM
Raid 5 273GB total space, 105GB free
Fresh install just a long time ago

I have run best practice adviser in the past and just re-ran it.

Only shows one error, which is the same error as before when I ran it:
DNS A resource record points to incorrect IP address

The host (A) resource record points to the incorrect IP address  The record should point o

Open in new window

server IP
VPN DHCP starts at:

After researching that error in the past I read that it is common for that error to show up as a false positive when you have VPN enabled on the sbs.

Also the server is up to date on updates, same with exchange SP and rollups

I did find these last night but didn't try them out, figured I'd ask you guys for your opinion.  Exchange isn't my forte by any means.

Thanks for your help
Simon Butler (Sembee)ConsultantCommented:
The first link you have posted is relatively harmless, so I would have no problem doing what it says. Just be patient, allow Exchange enough time to replicate the changes to the domain and do the OAB regeneration.

Cris HannaCommented:
by any chance has IPv6 been disabled on this server?
Simon Butler (Sembee)ConsultantCommented:
That is pretty much it. Just wait long enough for the process to run before doing the next step.

Cris HannaCommented:
If you have not already done so, I would run the Fix My Network wizard as well to see if it finds anything.
jtrabertAuthor Commented:
@Simon - Tried that no luck, still only the 4 items.  

@CrisHanna - Ran that as well didn't notice any changes
Cris HannaCommented:
You might try some of the troubleshooting tips here
SteveConnect With a Mentor Commented:
sounds like the OAB files are corrupted and it's just throwing a paddy.

Try deleting the OAB folder so it can recreate it from scratch.

Think it should be in the normal exchange folder in \exchangeoab\ <GUID>

just delete the <guid> folder and it's contents (probably best to take a backup copy) and then force OAB regeneration.
jtrabertAuthor Commented:
@totallytonto - that's exactly what I did, now it does actually update.  After I created a new Default book and followed this link:

 Now I have a problem with it updating the clients.

Clients are running Outlook 2010 and under send/receive options I made sure that "download offline address book" is checked and made sure it was part of the send/receive group but for some reason it doesn't update not unless I actually press the send/receive button.  If I remember right, it's suppose to do it automatically as well by default every 30min

Account Settings
Simon Butler (Sembee)ConsultantCommented:
You shouldn't need to touch the send/receive configuration.
The OAB is only downloaded once every 24 hours or within 30 minutes of Outlook being started. Therefore the behaviour you are seeing may well be correct.

agree, you shouldn't have to mess with the send/receive settings normally.

Have you checked the 'sync issues' folder to see if any errors are shown on the client?

Can you get into 'auto replies' or 'out of office' OK?
jtrabertAuthor Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.