SQL Server Backup Destination List

I did a manual SQL backup by right clicking and bringing up the Back Up Database wizard.  Since I had never used it I just wanted to see if it was easier than a script.  It's not.

Now I cannot get the Destination List to clear.  I see the list populated from various machines so it does not appear to be local to the SSMS installation.

There is a picture attached for your viewing pleasure.

Not an emergency but just annoying me.

Thank you in advance,

DB
SQLBackupDestinationList.jpg
LVL 1
dboteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony303Commented:
When you do a new manual backup, you could remove this path and put in the path to a more appropriate place, IE. not your C drive.

This path is then held and shows the next time you do a manual backup.

If you are at all interested the backup details are all stored in the system MSDB database.

As a look but don't touch task for you, put in the name of your DB in the last line of this script and you'll see a lot of information about the backups pertaining to that database....

USE msdb
GO


SELECT *
FROM Backupset b JOIN dbo.backupfile f
ON f.backup_set_id = b.backup_set_id
JOIN dbo.backupmediafamily mf
ON mf.media_set_id = b.media_set_id
WHERE Logical_Name like '%YOUR DATABASE NAME%'
0
geek_vjCommented:
The backup location refers to the default location which was given at the time of SQL Server installation (along with data, log & tempdb; there is a backup location configuration)
As such, if you want to remove it permanently and keep another location, you need to make the changes at registry level. Goto
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQLServer
Here look for BackupDirectory and change to the required path

You can also change the registry key values using T-SQL. Please find the below link for full details of it:
http://www.mssqltips.com/sqlservertip/1583/changing-the-default-sql-server-backup-folder/

Hope this helps!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dboteAuthor Commented:
geek_vj, thanks for the tip.  I went away on a business trip came back and the list was cleared.  I'm not exactly sure how that happened but that's what happened.  I do know no one else would have been in SSMS.

To my recollection I had never done a manual backup like that before as I generally use a script.  I had looked in the registry but did not see anything relating to a Distribution List.  Your tip reference will be a good start if I ever decide to use that feature again.

Thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.