Outlook 2010 Suggested Contacts Moving from one PC to another

I have moved my Outlook 2010 system from one pc to another.
In the next step I signed up to Office 365 as well and configured that.

Now since moving from one PC to other other, I do not have a suggested contacts list coming up anymore.  I can see the suggested contacts list in the Contacts Folder and there is some 1,700 items in there, but when I open a new email and start typing an email address, there is no list that appears.

Does anyone know how I can get this functionality back?

When I moved from POP to Exchange, I created a new Profile.  I went back into my old POP profile and could see the suggested contacts list was working in there so I am presuming the issue arose after I moved to Office 365 set-up.

Who is Participating?
KrasziConnect With a Mentor Commented:

This is a question of Auto-Complete List vs. Suggested Contacts

It is important to understand the difference between Auto-Complete List and Suggested Contacts.

Auto-Complete List

When you type an email address, Outlook remembers them and can offer auto-completion when adding recipients to a new email. The Auto-Complete list stores email addresses in local .Nk2 files in Outlook 2003 and 2007. They are now stored in a server-side hidden file starting with Exchange 2010. Therefore, those contacts remain accessible when a user has multiple computers with Outlook 2010 or later.

Suggested Contacts

Suggested Contacts is a special contact folder introduced with Exchange 2010 and then removed in Exchange 2013. This folder creates contacts for each new address a user send an e-mail to. The goal behind this feature was to prevent users from losing their contacts if their .Nk2 file gets corrupted (most users forget to manually add new contacts to their contact folder).

1) If you try to pusk Alt+k, then the new Outlook will build the autocomplete list for you again, because your addresses are there. It is a long process and needs no manual file copying.

2) You can do another thing: Open a new email, go to the "To" button, select all contacts, add them to the To field, save the message as draft. Then the autocomplete database will be filled with all your contacts.

3) This is the complicated way:
Grab the Stream_AutoComplete from the old profile : C:\Users\username1\AppData\Local\Microsoft\Outlook\RoamCache

Copy this to your desktop

Open C:\Users\username2\AppData\Local\Microsoft\Outlook\RoamCache in the new profile, right click on the Stream_Autocomplete file and select rename.

Copy the EXACT name text and rename the old Stream_Autocomplete file that is on your desktop by right clicking in and selecting paste. This ensures that the old Stream_Autocomplete file now has the same name as the new.

Copy and paste the Stram_Autocomplete file into the new users profile here: C:\Users\username2\AppData\Local\Microsoft\Outlook\RoamCache and select copy and replace.

Restart outlook

Now the new account has all the autocomplete settings from the original one:

it’s important that the old Stream_Autocomplete has the new Long name as the new profile otherwise it won’t work.

I hope it helps!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.