"Work folders" website not created in IIS 8

Dear members,

I am trying to use the new "Work folders" feature on Windows 2012 R2.
I am using a 2012 Trial version and Preview R2 version obviously.

Problem is easy to explain; When I am adding Workfolders feature, I do not get the website created in IIS. It is more than blocking my test.

I have already searched for a potential new website folder in local drive, updated Windows, removed/reinstalled IIS + work folders features, but in vain...

Would you please have an idea ?

Thank you

Kooljacks
KooljacksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cj_1969Commented:
Without a LOT of details its hard to say what might not be happening with your implementation.
Here is a link to a walk-through for setting up work folders in a VM lab environment.
I'm sure the basic steps, outisde of the VM references will still apply to your situation.
There indicate they are using the same server version as you so hopefully this will help ... http://blogs.technet.com/b/canitpro/archive/2013/07/15/step-by-step-creating-a-work-folders-test-lab-deployment-in-windows-server-2012-r2.aspx
0
KooljacksAuthor Commented:
Thank you for your answer.
I have followed your mentioned article, but with no success.

OK I am using 2012 R2 Datacenter preview
I have followed all instructions correctly, but It does not work and I don't know how to manage the workfolder website.
After installing the service, I connect to IIS and then see that default website and defaultAppPool are stopped. WAS service and another one are required.

As workfolders feature only uses https, I have installed the required services and started default website. Problem is that there is no content in default website, no trace of the freshly new installed workfolder feature.

Nevertheless, I have binded the defaultwesite to my CA certificate. But Of course, I get  nothing when I try to access workfolder server through the 8.1 client or through IE.

So I have already reinstalled the services & the whole server OS, without success. I have turned off the FW. My server is well reachable (PING) at workfolders.domainname.com

I don't know what else to try.
It seems easy to setup on the guides. I have seen on one guide that workfolders website was displayed on IIS, but it's not for me. I have checked the Inetpub folder but no clue...

Thank you a lot if you have any idea.

Kooljacks
0
cj_1969Commented:
look in the IIS Management tool, chances are any references to the work folder are virtual and located in a different directory/location ... so seeing nothing under the INetPub doesn't surprise me (sorry, I don't have a server to work off of to test any of this).

How did you install IIS?  At least under server 2k8 you have to explicitly add IIS to the system AND enable static content as an option.  I am a little concerned about the fact that you said the default website and app pool were stopped ... that is not normal and makes me think you have an issue with IIS.

First things first, get IIS running so that you can access the default website .... I would expect a normal IIS splash screen to show up when the root site is accessed and no other default content has been added.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

KooljacksAuthor Commented:
Thank you cj,
Actually workfolders uses Hostable Web Core.
For IIS, it has been installed automatically when adding workfolders feature.

Web Server IIS components are not all installed. Only the component "IIS Hostable Web Core " is installed.  That's why some services are missing. But I guess that it should work this way. Would you know how should I first install IIS before installing workfolders ? I have attached all available features under the Web Server IIS role.

What do you mean by virtual location? I did not set up any virtual directory and I don't see any virtual store.
0
KooljacksAuthor Commented:
I have now installed Full Web Server IIS role but problem remains.
Now everything is running well in IIS but still no content at all in Default website.

I have removed IIS and workfolders. Restarted, then reinstalled full IIS then workfolders, but no chances.
0
cj_1969Commented:
Hmmm ... it seems that the hostable service and full version of IIS do not play well together, go ahead and uninstall/remove the full IIS services.
I also found a series of posts indicating that work folders and the essential services service are not compatible.  If the essential services is configured on the machine it will cause work folders to stop working.

Take a look at this page and see if it has any more suggestions for you ... http://social.technet.microsoft.com/Forums/windowsserver/en-US/66ee0774-bf06-4949-bbf6-f803ef2f3367/work-folder-feature-do-not-work-if-essentials-role-is-installed
0
KooljacksAuthor Commented:
Hi again,

Thank you, I have also seen this article. I have already done this step: Uninstalling full service and only install Hostable web core feature and IIS management console to access the admin interface.

It does not help as when installing workfolders feature, web content is still empty.

Plus, Essentials service is not installed.

Any other clue ?
0
cj_1969Commented:
Sorry again for not being familiar with the application or being able to test any of this out ... so some of my questions might be very basic.
From my reading, the server side is purely a repository with a sync service running.
It sounds like you might have that part done already.
I did read that it is multi-user and that each user is supposed to sync to their own folder.
Have you identified anywhere where the storage location is for the server side files?
Have you configured the client to connect to the server and placed any files in the designated folder to sync to the server?
I'm sorry for the very basic questions but it will help to get a feel for where exactly you are and what to suggest next.
0
KooljacksAuthor Commented:
Agreed with you about the pure repository aspect, but problem is that it is reachable only through Workfolder clients and only by using https connection.

Actually, you choose the storage location when creating the "sync share" in Workfolders.
So I have created it without any problem.

Indeed, I have also tried to connect from clients to the server but no chance. Because I guess the https workfolder or Hostwebcore link website does not exist.
0
cj_1969Commented:
the installation seems straight forward from everything I have read.
Could it be the host name/URL that you are using to connect to it?
What if you use the IP address of your server instead of a host name?
0
cj_1969Commented:
ok, next step.
since you didn't mention doing this ... here are the steps to setting up a sync share.
http://searchwindowsserver.techtarget.com/tip/Windows-Server-2012-R2-Work-Folders-enable-BYOD-synchronization
0
KooljacksAuthor Commented:
Hi,

For me the problem is more located on the server itself, as I am not able to access this "workfolders" website.
I have created the syncshare without any problem.

It seems that my workfolder feature is not fully or correctly installed. A part is missing or I do not see it.
0
cj_1969Commented:
sorry for the delay ... been away and really busy
something seems to be getting missed.
it seems like a straightforward install/setup
If you go back to the very first link that I provided ...
have you set up the domain?
have you set up the client machines?  Are they a member of the domain?
after creating the syncshare have you granted access to the AD client?


Again, it feels like the client is not "finding" the server ... Check this step ...

2. Converting from Email address to Server Url

    When user enters the email address, such as Jane@contoso.com, the client will construct the Url as https://WorkFolders.contoso.com, and use that Url to communicate with the server. In production environment, you will need to publish the Url for the client to communicate to the server through reverse proxy. In testing, we’ll bypass the Url publication by configure the following regkey:

    Reg add HKCU\Software\Microsoft\Windows\CurrentVersion\WorkFolders /v ServerUrl /t REG_SZ /d http://syncServer.contoso.com
0
KooljacksAuthor Commented:
Finally, I have got the answer.
No website is created when installing workfolders. It's only working with a specific web service => HCS.

To bind certificate, I used netsh tool coomand.

Then I met other issues corrected by GA Rollup A (must be installed on Server and stations)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KooljacksAuthor Commented:
Problem not solved by the experts.
I could not accept other solutions (that were not).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.