Toshiba E-Studio Save to File Setup on Linux with Samba

Dear Experts,

I can't seem to get my Toshiba copier to save scanned documents to my Linux shared drive. This was not a problem when it was initially setup to save to a  Windows Server 2003 folder. The scan logs keeps having issue with network destination but I can confirm that the network path exists and I'm able to access it from my Win7 client machine.

Linux Debian Environment/Settings:
Server IP: 192.168.0.201
Mask: 255.255.255.0
Gateway: 192.168.0.1 (router)
Assigned DNS role
Assigned file server role with SAMBA configured

Toshiba Settings:
IP: 192.168.0.150
Mask: 255.255.255.0
Gateway: 192.168.0.1
Primary DNS: 192.168.0.201
Secondary DNS: 192.168.0.1
Linux user name: toshiba
Assigned Linux usergroup: ToshibaCopier

Linux Share Settings:
Linux path: /home/scan
Linux directory permission: 775
Windows path: \\192.168.0.201\Scanned Document
Owner: root
Group: ToshibaCopier


Can you please help point me in the right direction?

Many thanks in advance,
Ricky
Linux-Share-Drive-Setup.PNG
Linux-Share-Drive.PNG
Toshiba-IP-Settings.PNG
toshiba-dns-settings.PNG
Toshiba-Setup.PNG
scan-log.PNG
Share-Permission.PNG
Ricky NguyenITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wyliecoyoteukIT directorCommented:
Ironic, because the Toshiba is actually running Linux and Samba.
Only thing I can think of offhand, try removing the space from the folder name and making it all lower case.
I can try this later on when I'm in the office.
0
wyliecoyoteukIT directorCommented:
What do the samba logs say?
0
Ricky NguyenITAuthor Commented:
Hi wyliecoyoteuk, thanks for your reply. I don't see any errors referencing the Toshiba.
I changed the folder name as you suggested, without the spacing and all in lower case but still   same issue. Still says "Failed to connect to network destination. Check destination path".
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

wyliecoyoteukIT directorCommented:
Have you tried using the full user name?

i.e. domainname\username or computername\username

e.g. 192.168.0.201\toshiba (or probably better, linuxhostname\toshiba)

or toshiba@192.168.0.201 or toshiba@hostname
0
Ricky NguyenITAuthor Commented:
Still no luck with your suggested entries. Any other ideas?
0
wyliecoyoteukIT directorCommented:
All of your settings look correct.
If you log in to a windows PC with the toshiba username, can you browse to the share?
A workaround might be to use FTP.
I haven't had an opportunity to try it on a Linux box myself, but I have done Ricohs and Sharps in the past with no problem.
You could try enabling the "allow users to select network path" and see if they can browse the share that way.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ricky NguyenITAuthor Commented:
When you say "log into a windows PC with the toshiba username", you mean something like something similar to login into a domain? My Samber server isn't configure as a domain controller. Can you please clarify what you mean? Thank you.
0
Ricky NguyenITAuthor Commented:
Found the problem. I didn't create a toshiba samba user.  Thanks... User issue was spot on.
0
wyliecoyoteukIT directorCommented:
Great.
I meant to login to a PC and connect to the share with the toshiba user (as the user has to exist in samba, and usually in the windows domain too). This is a standard way of troubleshooting share permissions.
Glad you sorted it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.