Exchange 2010 installation

New domain, Installed Exchange 2010 on Windows Server 2008 R2 and then was instructed to go back and install it on Server 2012.  I had some issues removing exchange so I ended up going in ADSI edit (configuration) and removed CN=Microsoft Exchange (and autodiscover), rebuilding the problem server, and then installing Server 2012.  Now that I'm trying to install the Mailbox role on one of the servers I'm getting an error that I've never seen before... (attached)




The ExchangeSetupLogs  below"

[08/28/2013 15:49:42.0557] [1] Adding 'All Roles Common First' because it's marked AlwaysExecute.
[08/28/2013 15:49:42.0557] [1] Adding unique component 'All Roles Precompile Management Binaries'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox Permissions Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Common Perf Counters '
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Provision Server'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'All Active-Directory Roles Common'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Exchange 2003 Registry Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox Service Control (First)'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Exchange 2003 Core Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Exchange 2003 Pseudo-MTA Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Exchange 2003 MDB Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Datacenter Server License'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox Perf Counters'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Enable RPC-EPMAP firewall exception'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Enable Remote IIS Admin RPC firewall exception'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Transport Log Search Service'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Exchange 2003 Miscellaneous Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'InfoWorker Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Content Indexing Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mail Submission Service Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Replay Service Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Service Host Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'RPC Client Access Service Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Monitoring Service Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'MailboxExchangeCertificate'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'PowerShell Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'WSMan IIS Hosting Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Active Directory Topology Service Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox System Attendant Dependent Tasks'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Transport Common Service Control'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Service Host Service Control'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox Service Control (Last)'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Datacenter Common Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Datacenter Mailbox Configuration'
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Datacenter Mailbox Perf Counters'
[08/28/2013 15:49:42.0557] [1] Adding 'Datacenter Common Configuration Last' because it's marked AlwaysExecute.
[08/28/2013 15:49:42.0557] [1] Adding 'All Roles Common Last' because it's marked AlwaysExecute.
[08/28/2013 15:49:42.0557] [1] Adding unique component 'Mailbox SBS Configuration'
[08/28/2013 15:49:42.0557] [1] Adding 'Common SBS Configuration' because it's marked AlwaysExecute.
[08/28/2013 15:49:42.0557] [1] The following roles are installed: AdminToolsRole
[08/28/2013 15:49:42.0557] [1] Loaded 7 parameters from the configuration file "C:\Windows\Temp\ExchangeSetup\bin\EnterpriseServiceEndpointsConfig.xml".
[08/28/2013 15:49:42.0557] [1] Writing informational script to 'C:\ExchangeSetupLogs\Install-MailboxRole-20130828-1149420557979970906.ps1'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleBinPath = 'C:\Program Files\Microsoft\Exchange Server\V14\Bin'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleCreatePublicFolderDatabase = $False
[08/28/2013 15:49:42.0557] [1] Executing: $RoleCustomerFeedbackEnabled = $null
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterPath = 'C:\Program Files\Microsoft\Exchange Server\V14\Datacenter'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointABCHContactService = '<ServiceEndpoint><Url>http://pvt-contacts.msn.com/abservice/abservice.asmx</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointDomainPartnerManageDelegation = '<ServiceEndpoint><Url>https://domains.live.com/service/managedelegation.asmx</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointDomainPartnerManageDelegation2 = '<ServiceEndpoint><Url>https://domains.live.com/service/managedelegation2.asmx</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointLiveFederationMetadata = '<ServiceEndpoint><Url>https://nexus.passport.com/FederationMetadata/2006-12/FederationMetadata.xml</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointLiveGetUserRealm = '<ServiceEndpoint><Url>https://login.live.com/GetUserRealm.srf</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointLiveServiceLogin2 = '<ServiceEndpoint><Url>https://login.live.com/RST2.srf</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDatacenterServiceEndpointMsoFederationMetadata = '<ServiceEndpoint><Url>https://nexus.microsoftonline-p.com/FederationMetadata/2006-12/FederationMetadata.xml</Url></ServiceEndpoint>'
[08/28/2013 15:49:42.0557] [1] Executing: $RoleDbFilePath = $null
[08/28/2013 15:49:42.0573] [1] Executing: $RoleDomainController = 'DC01.superioruniform.com'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleFqdnOrName = 'EXMBX01.superioruniform.com'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleInstallationMode = 'Install'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleInstallPath = 'C:\Program Files\Microsoft\Exchange Server\V14\'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleInvocationID = '20130828-1149420557979970906'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleIsAdminToolsRoleInstalled = $True
[08/28/2013 15:49:42.0573] [1] Executing: $RoleIsDatacenter = $False
[08/28/2013 15:49:42.0573] [1] Executing: $RoleIsPartnerHosted = $False
[08/28/2013 15:49:42.0573] [1] Executing: $RoleIsServerSbs = $False
[08/28/2013 15:49:42.0573] [1] Executing: $RoleIsWindows8OrHigher = $True
[08/28/2013 15:49:42.0573] [1] Executing: $RoleLanguagePacksPath = 'C:\Apps\Service Pack 3_2\'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleLogFolderPath = $null
[08/28/2013 15:49:42.0573] [1] Executing: $RoleLoggedOnUser = 'SU\JonasD'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleLoggingPath = 'C:\Program Files\Microsoft\Exchange Server\V14\Logging'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleMailboxDatabaseName = 'Mailbox Database'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleMdbName = $null
[08/28/2013 15:49:42.0573] [1] Executing: $RoleNetBIOSName = 'EXMBX01'
[08/28/2013 15:49:42.0573] [1] Executing: $RolePreviousVersion = $null
[08/28/2013 15:49:42.0573] [1] Executing: $RoleProductPlatform = 'amd64'
[08/28/2013 15:49:42.0573] [1] Executing: $RolePublicFolderDatabaseName = 'Public Folder Database'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleRoleName = 'MailboxRole'
[08/28/2013 15:49:42.0573] [1] Executing: $RoleRoles = 'AdminToolsRole'
[08/28/2013 15:49:42.0589] [1] Executing: $RoleSetupLoggingPath = 'C:\ExchangeSetupLogs'
[08/28/2013 15:49:42.0589] [1] Executing: $RoleTargetVersion = '14.03.0123.004'
[08/28/2013 15:49:42.0589] [1] Executing: $RoleUpdatesDir = 'C:\Apps\Service Pack 3_2\Updates'
[08/28/2013 15:49:42.0589] [1] Setup failed previously while performing the action Install.  Looking for the failed task with ID ProvisionServerComponent___cff4878349854618beeb2c9e17cc5214.
[08/28/2013 15:49:42.0589] [1] 211 tasks were found to execute.
[08/28/2013 15:49:42.0589] [1] Processing component 'Provision Server' (Provisioning the Exchange server object).
[08/28/2013 15:49:42.0589] [1] Executing:
          if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) )
          {
            Update-RmsSharedIdentity -ServerName $RoleNetBIOSName
          }
       
[08/28/2013 15:49:42.0589] [2] Active Directory session settings for 'Update-RmsSharedIdentity' are: View Entire Forest: 'True', Configuration Domain Controller: 'DC01.superioruniform.com', Preferred Global Catalog: 'DC01.superioruniform.com', Preferred Domain Controllers: '{ DC01.superioruniform.com }'
[08/28/2013 15:49:42.0589] [2] Beginning processing Update-RmsSharedIdentity -ServerName:'EXMBX01'
[08/28/2013 15:49:42.0713] [2] RMS Shared Identity user 'FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042' not found in Global Catalog.  Trying root domain.
[08/28/2013 15:49:42.0729] [2] Unexpected Error
[08/28/2013 15:49:42.0729] [2] RMS Shared Identity user FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 not found.
[08/28/2013 15:49:42.0729] [2] Ending processing Update-RmsSharedIdentity
[08/28/2013 15:49:42.0729] [1] The following 1 error(s) occurred during task execution:
[08/28/2013 15:49:42.0729] [1] 0.  ErrorRecord: RMS Shared Identity user FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 not found.
[08/28/2013 15:49:42.0729] [1] 0.  ErrorRecord: Microsoft.Exchange.Management.Tasks.RmsSharedIdentityUserNotFoundException: RMS Shared Identity user FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 not found.
   at Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity.FindRmsSharedIdentityUser()
   at Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity.Link()
[08/28/2013 15:49:42.0729] [1] The following error was generated when "$error.Clear();
          if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) )
          {
            Update-RmsSharedIdentity -ServerName $RoleNetBIOSName
          }
        " was run: "RMS Shared Identity user FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 not found.".
[08/28/2013 15:49:42.0729] [1] RMS Shared Identity user FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 not found.
[08/28/2013 15:49:42.0729] [1] [ERROR-REFERENCE] Id=ProvisionServerComponent___cff4878349854618beeb2c9e17cc5214 Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
[08/28/2013 15:49:42.0729] [1] Setup is stopping now because of one or more critical errors.
[08/28/2013 15:49:42.0745] [1] Finished executing component tasks.
[08/28/2013 15:49:42.0776] [1] Ending processing Install-MailboxRole
[08/28/2013 15:57:05.0422] [0] End of Setup
[08/28/2013 15:57:05.0422] [0] **********************************************
Exchange.PNG
ExchangeSetup.log
jonasdurstAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mpilarczykCommented:
Run setup /PrepareAD again
0
jonasdurstAuthor Commented:
I'm trying to run that in powershell but it's just sitting at:

PS C:\apps\Exch2k10 SP2> setup.com /PrepareAD

Welcome to Microsoft Exchange Server 2010 Unattended Setup

Preparing Exchange Setup

    Copying Setup FilesPS C:\apps\Exch2k10 SP2>
0
jonasdurstAuthor Commented:
I had to remove the CA and HT roles from one server and remove the exchange tools on the the other intended mailbox role server.  Removed all exchange server roles and tools from the environment bascially.  Then I reran setup on the one server to re-install CA and HT using the  setup /PrepareAD and that did the trick.  I was able to search in AD and find the FederatedEmail...  account.  I then was able to install the mailbox role on the other server and it worked fine.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mpilarczykCommented:
Sorry I couldn't help more but I was away from keyboard for a while.
0
jonasdurstAuthor Commented:
There was more to fixing the issues than just running a suggested command. I had to get the environment ready to except that command.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.