Windows 7 DNS Problem

I am currently having a problem with all my Windows 7 workstations looking at the external DNS before it references the Internal DNS. Example I can ping a local server by name on any other system than the Windows 7 System and it shows the correct Internal IP but when I do it on the Windows 7 system it doesn’t know where to go and I get a request time out, if I do a NS lockup it gives me the IP of the external DNS source, not sure how to get around this.

Thanks
ahmad1467Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike RoeCommented:
Are you using static IP or DHCP assigned
0
JayPhillips82Commented:
Check your IP settings. If all other machines are resolving ok then it sounds like your Windows 7 box has a static IP. Change it to DHCP or change the static IP to reflect your internal network.
0
ahmad1467Author Commented:
I am using DHCP on and static and I get the same results, one thing  I did find is that both DNS Server records are getting populated with the IPV6 address and when you ping a machine by name it tries to resolve to the IPV6 address and not the IPV4 address. Also if the machine has multiple NIcs and multiple addresses, A-records are getting created for all connections even though I only want 1 internal address to show in DNS. I tried deleting the A records out of DNS but they keep coming back.
0
JayPhillips82Commented:
To get the A records to stop populating in DNS, you can go to properties of the local area connection (the one you don't want to populate). In the IPv4 and IPv6 properties, click on Advanced. Click on the DNS tab and uncheck the "Register this connection's address in DNS" check box. Then you can manually delete them in DNS. They shouldn't populate again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BillBondoCommented:
I would get rid of the external dns and let your servers be the only ones dns
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.