Backups Failing on Hyper-V Setup

Hi all,

Having some issues with a new Hyper-V setup and tape backups. We have a Windows Server 2008 R2 system with Hyper-V role running an SBS 2011 VM and Server 2008 R2 (terminal services) VM.

We are running into some issues with Backup Exec. It appears to be backing up the host system OK but then fails backing up the virtual machines. The error we're seeing is:

Error category    : Resource Errors
Error             : a0009650 - A snapshot could not be created.  The most probable cause is a disk signature collision between two or more VHDs that are assigned to the virtual machine.
For additional information regarding this error refer to link V-79-40960-38480


I've spend a considerable amount of time with Symantec support trying to troubleshoot this issue. Have checked disk signatures on the host and virtual machines, all checks out OK. We've attached the 2 VHDs for the VMs to the host disk management to reset any issues and this came back clear. I've configured a backup in Windows Server Backup to run to an external HDD and this has failed also.

Checking VSS status shows that the 'Microsoft Hyper-V VSS Writer' is in State: [1] Stable, Last error: Unexpected error
The 'ASR Writer' has also occasionally fallen over. Symantec support have told me that it's looking more like an issue with VSS generally than an issue with Backup Exec (considering Windows backup also fails).

The system was installed a few months ago and Backup Exec has not worked from day 1. Backup Exec System Recovery has also been running from day 1 on a different schedule and this has worked flawlessly backing up to another external HDD.

Any suggestions?

Cheers
greentriangleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BSRITCommented:
try setting up a back with windows back and see does it work?

take it you have already tried removing / re-installing backup exec.

also did you already see this:
http://www.symantec.com/business/support/index?page=content&id=TECH186773

to be honest i never set my hyper-v environments up this way.. i normally use windows backup to backup the hyper-v server, (excluding vhd / vhdx files) , and then install backup software on the individual vm's and back them up separately.
0
Haresh NikumbhSr. Tech leadCommented:
So both Vm backups are getting failed.. can you send me vss writers status for the vm

to check vss writer run following command on the command prompt

Vssadmin list writers

Also while executing backup .. does it creating any error events in the VM (VSS related events)
0
greentriangleAuthor Commented:
Hi guys,

Yes I've reinstalled Backup Exec. I've also been through that support note with a Symantec technician and checked the disk signatures on the host and VMs. They all appeared to be clear but we ran through the process of attaching/removing the VHDs to the host disk management anyway just to be safe, this didn't change anything.

The terminal server VM (TSERVER) is clear of VSS errors. The host OS has the following:

Writer name: 'Microsoft Hyper-V VSS Writer'
   Writer Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
   Writer Instance Id: {ba6c879c-f650-4bfb-8577-89a1a0be9a3b}
   State: [1] Stable
   Last error: Unexpected error

The SBS 2011 VM (SBSERVER) has a number of VSS writers in status awaiting completion.

I've tried running Windows Server Backup but it fails instantly. I'll give the servers a restart later today to clear VSS errors and try running it again excluding the VM partitions, will post back with results when it's done.

Cheers.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

greentriangleAuthor Commented:
I've restarted the host and VMs and run Windows Server Backup using the host OS partition only, the SBS partition only, the terminal server partition only and the host partition + terminal server partition.

All of these backups passed, except for the SBS partition, which appears to be consistent with what we're seeing in Backup Exec 2012 (backup job works for the host + terminal server VM, but fails when including the SBS VM).

As previously stated the SBS has a number of VSS writers in "State: [5] Waiting for completion". I've also found another one (SPSearch4 VSS Writer) in "State: [8] Failed" "Last error: Inconsistent shadow copy".
0
greentriangleAuthor Commented:
I have resolved this issue now.

Backups were failing on both Backup Exec and Windows Server Backup due to SharePoint 2010 SP1 which was installed via Windows updates during the initial setup.

The fix is as follows:

Run the following command in an elevated SharePoint 2010 Management Shell:
(get-spserver $env:computername).NeedsUpgrade

Open in new window



If it returns "True" then:
In an elevated command prompt, change directory to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN
Run: PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
greentriangleAuthor Commented:
Issue resolved.
0
greentriangleAuthor Commented:
Issue was not resolved by any other contributors. This had been an issue for months and the fix provided worked straight away.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.