Cisco 3750 with Shoretel Phone VLAN Tagging with multiple Networks

I have two cisco 3750Gs stacked with a trunk uplink that is caring 3 VLANs. VLAN1 (Public VLAN), VLAN 31 (Private VLAN), and the VOIP System on VLAN 50.

My understanding is that each port where im going to have a computer/phone needs to be a trunk. PC goes through the native VLAN (untagged), and the phones on the tagged vlan with DHCP options that i have in place.

I have half of the ports on vlan1 and half on vlan 31 that need to be able to access dhcp on untagged ports for PC traffic. The phones also need to be able to see VLAN 50 tagged so it jumps on the VOIP lan.

This is what I have in place for all ports (not the uplink) but does not give the PCs an IP address on the "native vlan of 31":

switchport trunk native vlan 1
switchport trunk allowed vlan 1,200
switchport trunk encap dot1q
switchport mode trunk

I am able to assign access ports to different ports and put em on any of these vlan and they work just fine. Just trouble getting the native vlan 1 and 31 to present itself as untagged when i make it a trunk port.
LVL 1
systems_QuixoteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rauenpcCommented:
A trunk can only have one native or untagged vlan. By default it is vlan 1 unless you specify otherwise. When filtering down vlans manually by using the "switch port trunk allowed vlan [list]" this also filters the native vlan. So if you set the native vlan to 31 and also want vlan 50 tagged for voice, you need to allow both vlan 31 and 50.

Not sure if it was just a typo, but your example set the native vlan to 1, and not 31. Vlan 31 is not in the allowed list.
0
rauenpcCommented:
Also, instead of configuring trunks, you can probably use the voice vlan feature instead. You'll also need to enable Lldp.
0
getzjdCommented:
Here is our config for a standard port with both a PC and phone.  Native vlan is 1 thus you do not have to specify it

interface switchport 0/1
  no shutdown
  switchport mode trunk
  qos trust cos

Here is a port with something that sits on the native vlan for phones

interface switchport 0/17
    no shutdown
  switchport mode trunk
  switchport voice vlan 35
  qos trust cos

Make sure you have a vlan interface with an IP such as vlan 35.  Once you do that just create the DHCP scope



interface vlan 1
  description LAN
  ip address  10.35.1.110  255.255.248.0
  ip flow ingress
  ip flow egress
  ip route-cache express
  no shutdown

interface vlan 35
  description Voice
  ip address  192.168.35.1  255.255.255.0
  ip flow ingress
  ip flow egress
  ip route-cache express
  no shutdown
0
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Craig BeckCommented:
If your PCs use VLAN tagging you can use trunks, but generally you'd use access ports for PC connectivity, and the voice VLAN for phones.

The previous expert's post is technically incorrect as the voice VLAN doesn't apply on a trunk port - the command is ignored.

If the phones use CDP to get their Voice VLAN info you just need this...

interface FastEthernet0/1
 switchport
 switchport mode access
 switchport access vlan 31
 switchport voice vlan 50
 spanning-tree portfast


If the phones don't use CDP they'll need to first join a Data VLAN, then receive the Voice VLAN info via LLDP, DHCP or RADIUS, then shift to the Voice VLAN.  For that scenario you'd need this...

interface FastEthernet0/1
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 1,31,50
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
systems_QuixoteAuthor Commented:
Craigbet, no CDP used.

Since I have two separate data networks I was having issues getting the native VLANs separated but still allow trunk access for vlan 50(voice).

DHCP will supply all the options for vlan assignments and server connection for shoretel phones.

Craigbet & rauenpc your commands resolved this.

Data vlan 1
Data vlan 31
VoIP vlan 50

Data vlan 1 + VoIP vlan 50 config:
Interface gig 1/0/1
Switchport trunk allowed vlan 50
Switchport trunk encap dot1q
Switchport mode trunk

Data vlan 31 + VoIP vlan 50
Interface gig 1/0/2
Switchport trunk native vlan 31 (not sure I got the lingo correct, is have to reference back my interface config)
Switchport trunk allowed vlan 31,50
Switchport trunk encap dot1q
Switchport mode trunk

Any other recommended changes to smooth out the voice vlan deployment?
0
Craig BeckCommented:
So, your config is correct as per your last post.  You'll need to set VLAN options in DHCP for the phones (or manually configure the VLAN ID on the phone itself), but you're good to go now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.